~ubuntu-branches/ubuntu/karmic/xulrunner/karmic

« back to all changes in this revision

Viewing changes to debian/patches/01_js_binary.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mike Hommey
  • Date: 2006-06-15 01:05:34 UTC
  • Revision ID: james.westby@ubuntu.com-20060615010534-6q08icmnnidcqrfn
Tags: 1.8.0.4-1
* The "finally a new upstream" release.
* Fixes the following security vulnerabilities:
  CVE-2006-2775, CVE-2006-2776, CVE-2006-2778, CVE-2006-2780,
  CVE-2006-2782, CVE-2006-2783, CVE-2006-2784, CVE-2006-2785,
  CVE-2006-2786, CVE-2006-2787.

* debian/patches/00_securityfix.dpatch: Removed, since this release includes
  all the security changes we brought from CVS in this patch.
* debian/patches/90_js_mipsel_endianness.dpatch: Removed, since it was
  applied upstream.
* debian/patches/01_installer.dpatch,
  debian/patches/01_javaxpcom.dpatch: Removed parts that were applied
* debian/patches/00list: Updated accordingly.
* debian/patches/01_distclean.dpatch,
  debian/patches/01_xpcomglue.dpatch: Adapted to upstream changes.
  upstream.
* debian/patches/99_configure.dpatch: Updated.

* debian/patches/01_pyxpcom.dpatch: Use a make variable for PYTHON_SO.
* debian/patches/90_unichar_alignment.dpatch.
* debian/patches/00list: Added 90_unichar_alignment.
* debian/rules:
  + Set this PYTHON_SO variable when building python modules.
  + Disabled strict aliasing from optimized builds.
  + Build with minimal toc on ppc64. Closes: #361188.
  + Fix for Gecko date extraction from client.mk.
* debian/mozconfig: Set default mozilla home.
* debian/control: Replaced some Conflicts with Replaces, which should be fine.

* debian/rules, debian/control, debian/mozconfig, debian/python-xpcom.dirs.in,
  debian/python-xpcom.install.in, debian/libmozillainterfaces-java.install,
  debian/libmozillainterfaces-java.links, debian/libxul-common.*,
  debian/libxul0d.*, debian/*.conf: Remove pyxpcom and javaxpcom (again)
  packages and build. We want this release not to go through NEW (again).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 01_js_binary.dpatch by  <Mike Hommey <glandium@debian.org>>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: - JS binary. bz#331776
 
6
## DP: - Add readline support to xpcshell.
 
7
 
 
8
@DPATCH@
 
9
 
 
10
=== config/autoconf.mk.in
 
11
==================================================================
 
12
--- xulrunner/config/autoconf.mk.in     (revision 7)
 
13
+++ xulrunner/config/autoconf.mk.in     (local)
 
14
@@ -73,6 +73,9 @@
 
15
 MOZ_X11                        = @MOZ_X11@
 
16
 
 
17
 MOZ_JS_LIBS               = @MOZ_JS_LIBS@
 
18
+ENABLE_JS_BINARY       = @ENABLE_JS_BINARY@
 
19
+HAVE_READLINE          = @HAVE_READLINE@
 
20
+READLINE_LIBS          = @READLINE_LIBS@
 
21
 
 
22
 MOZ_GFX_TOOLKIT_LDFLAGS     = @MOZ_GFX_TOOLKIT_LDFLAGS@
 
23
 MOZ_WIDGET_TOOLKIT_LDFLAGS  = @MOZ_WIDGET_TOOLKIT_LDFLAGS@
 
24
=== config/rules.mk
 
25
==================================================================
 
26
--- xulrunner/config/rules.mk   (revision 7)
 
27
+++ xulrunner/config/rules.mk   (local)
 
28
@@ -898,7 +898,7 @@
 
29
 ifeq ($(CPP_PROG_LINK),1)
 
30
        $(CCC) $(WRAP_MALLOC_CFLAGS) $(CXXFLAGS) -o $@ $< $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(LIBS_DIR) $(LIBS) $(OS_LIBS) $(EXTRA_LIBS) $(WRAP_MALLOC_LIB) $(PROFILER_LIBS) $(BIN_FLAGS)
 
31
 else
 
32
-       $(CC) $(WRAP_MALLOC_CFLAGS) $(CFLAGS) $(OUTOPTION)$@ $< $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(LIBS_DIR) $(LIBS) $(OS_LIBS) $(EXTRA_LIBS) $(WRAP_MALLOC_LIB) $(PROFILER_LIBS) $(BIN_FLAGS)
 
33
+       $(CC) $(WRAP_MALLOC_CFLAGS) $(CFLAGS) $(OUTOPTION)$@ $< $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(LIBS_DIR) $(LIBS) $(OS_LIBS) $(EXTRA_LIBS) $(WRAP_MALLOC_LIB) $(PROFILER_LIBS) $(BIN_FLAGS) $(PROG_LIBS)
 
34
 endif # CPP_PROG_LINK
 
35
 endif # WINNT && !GNU_CC
 
36
 endif # OS/2 VACPP
 
37
=== configure.in
 
38
==================================================================
 
39
--- xulrunner/configure.in      (revision 7)
 
40
+++ xulrunner/configure.in      (local)
 
41
@@ -5116,6 +5116,40 @@
 
42
 AC_SUBST(JS_ULTRASPARC_OPTS)
 
43
 
 
44
 dnl ========================================================
 
45
+dnl = Enable building of the js standalone binary
 
46
+dnl ========================================================
 
47
+MOZ_ARG_ENABLE_BOOL(js-binary,
 
48
+[  --enable-js-binary      Build the standalone JS program],
 
49
+    ENABLE_JS_BINARY=1,
 
50
+    ENABLE_JS_BINARY= )
 
51
+AC_SUBST(ENABLE_JS_BINARY)
 
52
+
 
53
+if test -n "$ENABLE_JS_BINARY"; then
 
54
+    dnl readline Support
 
55
+    dnl ========================================================
 
56
+    READLINE_DIR=no
 
57
+    MOZ_ARG_WITH_STRING(readline,
 
58
+    [  --with-readline[=PFX]
 
59
+                              Use libreadline [installed at prefix PFX]],
 
60
+        READLINE_DIR=$withval)
 
61
+    
 
62
+    if test -n "${READLINE_DIR}" -a "${READLINE_DIR}" != "no"; then
 
63
+        _SAVE_LDFLAGS=$LDFLAGS
 
64
+        LDFLAGS="-L${READLINE_DIR}/lib $LDFLAGS"
 
65
+        AC_CHECK_LIB(readline, readline, [HAVE_READLINE=1 READLINE_LIBS="-lreadline"], 
 
66
+           [HAVE_READLINE= READLINE_LIBS=])
 
67
+        LDFLAGS=$_SAVE_LDFLAGS
 
68
+    fi
 
69
+    
 
70
+    if test "${READLINE_DIR}" -a -d "${READLINE_DIR}" -a "$HAVE_READLINE" = 1; then
 
71
+        READLINE_LIBS="-L${READLINE_DIR}/lib ${READLINE_LIBS}"
 
72
+    fi
 
73
+fi
 
74
+
 
75
+AC_SUBST(HAVE_READLINE)
 
76
+AC_SUBST(READLINE_LIBS)
 
77
+
 
78
+dnl ========================================================
 
79
 dnl =
 
80
 dnl = Feature options that require extra sources to be pulled
 
81
 dnl =
 
82
=== js/src/Makefile.in
 
83
==================================================================
 
84
--- xulrunner/js/src/Makefile.in        (revision 7)
 
85
+++ xulrunner/js/src/Makefile.in        (local)
 
86
@@ -54,6 +54,16 @@
 
87
 RESFILE                = js$(MOZ_BITS)40.res
 
88
 endif
 
89
 
 
90
+ifdef ENABLE_JS_BINARY
 
91
+SIMPLE_PROGRAMS        = js
 
92
+PROG_LIBS      = -L. $(MOZ_JS_LIBS) $(NSPR_LIBS)
 
93
+$(SIMPLE_PROGRAMS): $(DLL_PREFIX)$(LIBRARY_NAME)$(DLL_SUFFIX)
 
94
+ifdef HAVE_READLINE
 
95
+PROG_LIBS      += $(READLINE_LIBS)
 
96
+DEFINES                = -DEDITLINE
 
97
+endif
 
98
+endif
 
99
+
 
100
 PACKAGE_FILE = js.pkg
 
101
 
 
102
 # JavaScript must be built shared, even for static builds, as it is used by
 
103
=== js/src/xpconnect/shell/Makefile.in
 
104
==================================================================
 
105
--- xulrunner/js/src/xpconnect/shell/Makefile.in        (revision 69)
 
106
+++ xulrunner/js/src/xpconnect/shell/Makefile.in        (local)
 
107
@@ -74,7 +74,7 @@
 
108
 # look at mozilla/js/src/editline, which is license-free (but not part
 
109
 # of the mozilla build.)
 
110
 #
 
111
-ifdef JS_READLINE
 
112
+ifdef HAVE_READLINE
 
113
 DEFINES += -DEDITLINE
 
114
-LIBS += -lreadline $(JS_READLINE_EXTRA_LIBS)
 
115
+LIBS += $(READLINE_LIBS)
 
116
 endif