~ubuntu-branches/ubuntu/karmic/xulrunner/karmic

« back to all changes in this revision

Viewing changes to debian/patches/80_entropy.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Mike Hommey
  • Date: 2006-06-15 01:05:34 UTC
  • Revision ID: james.westby@ubuntu.com-20060615010534-6q08icmnnidcqrfn
Tags: 1.8.0.4-1
* The "finally a new upstream" release.
* Fixes the following security vulnerabilities:
  CVE-2006-2775, CVE-2006-2776, CVE-2006-2778, CVE-2006-2780,
  CVE-2006-2782, CVE-2006-2783, CVE-2006-2784, CVE-2006-2785,
  CVE-2006-2786, CVE-2006-2787.

* debian/patches/00_securityfix.dpatch: Removed, since this release includes
  all the security changes we brought from CVS in this patch.
* debian/patches/90_js_mipsel_endianness.dpatch: Removed, since it was
  applied upstream.
* debian/patches/01_installer.dpatch,
  debian/patches/01_javaxpcom.dpatch: Removed parts that were applied
* debian/patches/00list: Updated accordingly.
* debian/patches/01_distclean.dpatch,
  debian/patches/01_xpcomglue.dpatch: Adapted to upstream changes.
  upstream.
* debian/patches/99_configure.dpatch: Updated.

* debian/patches/01_pyxpcom.dpatch: Use a make variable for PYTHON_SO.
* debian/patches/90_unichar_alignment.dpatch.
* debian/patches/00list: Added 90_unichar_alignment.
* debian/rules:
  + Set this PYTHON_SO variable when building python modules.
  + Disabled strict aliasing from optimized builds.
  + Build with minimal toc on ppc64. Closes: #361188.
  + Fix for Gecko date extraction from client.mk.
* debian/mozconfig: Set default mozilla home.
* debian/control: Replaced some Conflicts with Replaces, which should be fine.

* debian/rules, debian/control, debian/mozconfig, debian/python-xpcom.dirs.in,
  debian/python-xpcom.install.in, debian/libmozillainterfaces-java.install,
  debian/libmozillainterfaces-java.links, debian/libxul-common.*,
  debian/libxul0d.*, debian/*.conf: Remove pyxpcom and javaxpcom (again)
  packages and build. We want this release not to go through NEW (again).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 80_entropy.dpatch by  <glandium@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Remove code that called netstat to gain so entropy. It's pretty
 
6
## DP: useless on a Linux system. Thanks Wichert Akkerman. bz#51429.
 
7
 
 
8
@DPATCH@
 
9
 
 
10
=== security/nss/lib/freebl/unix_rand.c
 
11
==================================================================
 
12
--- xulrunner/security/nss/lib/freebl/unix_rand.c       (revision 22)
 
13
+++ xulrunner/security/nss/lib/freebl/unix_rand.c       (local)
 
14
@@ -880,12 +880,14 @@
 
15
        safe_pclose(fp);
 
16
     }
 
17
 #endif
 
18
+#ifndef LINUX 
 
19
     fp = safe_popen(netstat_ni_cmd);
 
20
     if (fp != NULL) {
 
21
        while ((bytes = fread(buf, 1, sizeof(buf), fp)) > 0)
 
22
            RNG_RandomUpdate(buf, bytes);
 
23
        safe_pclose(fp);
 
24
     }
 
25
+#endif
 
26
 
 
27
 }
 
28
 #else