~ubuntu-branches/ubuntu/lucid/ffmpeg-extra/lucid

« back to all changes in this revision

Viewing changes to debian/patches/neon/0020-ARM-remove-unnecessary-.fpu-neon-directives.patch

  • Committer: Bazaar Package Importer
  • Author(s): Reinhard Tartler, Reinhard Tartler, Loïc Minier
  • Date: 2009-10-14 09:15:50 UTC
  • Revision ID: james.westby@ubuntu.com-20091014091550-7z06g45xfd40wbsc
Tags: 4:0.5+svn20090706-2ubuntu2
[ Reinhard Tartler ]
* merge from the 'ffmpeg' package
* Make arguments of av_set_pts_info() unsigned.
* update debian/changelog
* use patch for issue1245 from git.ffmpeg.org
* Support constant-quant encoding for libtheora, LP: #356322
* increase swscale compile time width (VOF/VOFW), LP: #443264
* Add missing Conflicts/Replaces to ensure a working upgrade patch from
  intrepid/jaunty. LP: #418785

[ Loïc Minier ]
* Update config for karmic's armel toolchain.
* Enable neon flavour; LP: #383240.
* Update NEON confflags to assume v7 and VFP.
* Add backported NEON patches from ffmpeg trunk; see debian/patches/neon/.
* Pass proper --cpu and --extra-flags on armel.
* Pass -fPIC -DPIC to neon pass.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From cf79e9ce120293a3d8fd6887298283c27ee866d4 Mon Sep 17 00:00:00 2001
 
2
From: mru <mru@9553f0bf-9b14-0410-a0b8-cfaf0461ba5b>
 
3
Date: Fri, 2 Oct 2009 19:35:12 +0000
 
4
Subject: [PATCH 20/20] ARM: remove unnecessary .fpu neon directives
 
5
 
 
6
git-svn-id: file:///var/local/repositories/ffmpeg/trunk@20151 9553f0bf-9b14-0410-a0b8-cfaf0461ba5b
 
7
---
 
8
 libavcodec/arm/dsputil_neon_s.S   |    1 -
 
9
 libavcodec/arm/h264dsp_neon.S     |    2 --
 
10
 libavcodec/arm/h264idct_neon.S    |    2 --
 
11
 libavcodec/arm/mdct_neon.S        |    1 -
 
12
 libavcodec/arm/simple_idct_neon.S |    2 --
 
13
 5 files changed, 0 insertions(+), 8 deletions(-)
 
14
 
 
15
diff --git a/libavcodec/arm/dsputil_neon_s.S b/libavcodec/arm/dsputil_neon_s.S
 
16
index 71d09c6..f039349 100644
 
17
--- a/libavcodec/arm/dsputil_neon_s.S
 
18
+++ b/libavcodec/arm/dsputil_neon_s.S
 
19
@@ -23,7 +23,6 @@
 
20
 #include "asm.S"
 
21
 
 
22
         preserve8
 
23
-        .fpu neon
 
24
         .text
 
25
 
 
26
         .macro pixels16 avg=0
 
27
diff --git a/libavcodec/arm/h264dsp_neon.S b/libavcodec/arm/h264dsp_neon.S
 
28
index 03e21f1..78f312d 100644
 
29
--- a/libavcodec/arm/h264dsp_neon.S
 
30
+++ b/libavcodec/arm/h264dsp_neon.S
 
31
@@ -20,8 +20,6 @@
 
32
 
 
33
 #include "asm.S"
 
34
 
 
35
-        .fpu neon
 
36
-
 
37
         .macro transpose_8x8 r0 r1 r2 r3 r4 r5 r6 r7
 
38
         vtrn.32         \r0, \r4
 
39
         vtrn.32         \r1, \r5
 
40
diff --git a/libavcodec/arm/h264idct_neon.S b/libavcodec/arm/h264idct_neon.S
 
41
index 6527390..d30e703 100644
 
42
--- a/libavcodec/arm/h264idct_neon.S
 
43
+++ b/libavcodec/arm/h264idct_neon.S
 
44
@@ -21,8 +21,6 @@
 
45
 #include "asm.S"
 
46
 
 
47
         preserve8
 
48
-        .fpu neon
 
49
-
 
50
         .text
 
51
 
 
52
 function ff_h264_idct_add_neon, export=1
 
53
diff --git a/libavcodec/arm/mdct_neon.S b/libavcodec/arm/mdct_neon.S
 
54
index 5cd4647..f089519 100644
 
55
--- a/libavcodec/arm/mdct_neon.S
 
56
+++ b/libavcodec/arm/mdct_neon.S
 
57
@@ -21,7 +21,6 @@
 
58
 
 
59
 #include "asm.S"
 
60
 
 
61
-        .fpu neon
 
62
         .text
 
63
 
 
64
 function ff_imdct_half_neon, export=1
 
65
diff --git a/libavcodec/arm/simple_idct_neon.S b/libavcodec/arm/simple_idct_neon.S
 
66
index 0882481..4c329d8 100644
 
67
--- a/libavcodec/arm/simple_idct_neon.S
 
68
+++ b/libavcodec/arm/simple_idct_neon.S
 
69
@@ -45,8 +45,6 @@
 
70
 #define w7 d1[2]
 
71
 #define w4c d1[3]
 
72
 
 
73
-        .fpu neon
 
74
-
 
75
         .macro idct_col4_top
 
76
         vmull.s16       q7,  d6,  w2    /* q9   = W2 * col[2] */
 
77
         vmull.s16       q8,  d6,  w6    /* q10  = W6 * col[2] */
 
78
-- 
 
79
1.6.3.3
 
80