~ubuntu-branches/ubuntu/lucid/ffmpeg-extra/lucid

« back to all changes in this revision

Viewing changes to debian/patches/neon/0021-ARM-check-for-VFP-register-arguments.patch

  • Committer: Bazaar Package Importer
  • Author(s): Reinhard Tartler, Reinhard Tartler, Loïc Minier
  • Date: 2009-10-14 09:15:50 UTC
  • Revision ID: james.westby@ubuntu.com-20091014091550-7z06g45xfd40wbsc
Tags: 4:0.5+svn20090706-2ubuntu2
[ Reinhard Tartler ]
* merge from the 'ffmpeg' package
* Make arguments of av_set_pts_info() unsigned.
* update debian/changelog
* use patch for issue1245 from git.ffmpeg.org
* Support constant-quant encoding for libtheora, LP: #356322
* increase swscale compile time width (VOF/VOFW), LP: #443264
* Add missing Conflicts/Replaces to ensure a working upgrade patch from
  intrepid/jaunty. LP: #418785

[ Loïc Minier ]
* Update config for karmic's armel toolchain.
* Enable neon flavour; LP: #383240.
* Update NEON confflags to assume v7 and VFP.
* Add backported NEON patches from ffmpeg trunk; see debian/patches/neon/.
* Pass proper --cpu and --extra-flags on armel.
* Pass -fPIC -DPIC to neon pass.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 2062a3d147ea6123eb0aa2b010be6c662e58f291 Mon Sep 17 00:00:00 2001
 
2
From: mru <mru@9553f0bf-9b14-0410-a0b8-cfaf0461ba5b>
 
3
Date: Mon, 20 Jul 2009 22:30:24 +0000
 
4
Subject: [PATCH] ARM: check for VFP register arguments
 
5
 
 
6
git-svn-id: file:///var/local/repositories/ffmpeg/trunk@19474 9553f0bf-9b14-0410-a0b8-cfaf0461ba5b
 
7
---
 
8
 configure            |    6 ++++++
 
9
 libavcodec/arm/asm.S |    9 +++++++++
 
10
 2 files changed, 15 insertions(+), 0 deletions(-)
 
11
 
 
12
diff --git a/configure b/configure
 
13
index 7459215..d0c7096 100755
 
14
--- a/configure
 
15
+++ b/configure
 
16
@@ -917,6 +917,7 @@ HAVE_LIST="
 
17
     termios_h
 
18
     threads
 
19
     truncf
 
20
+    vfp_args
 
21
     winsock2_h
 
22
     yasm
 
23
 "
 
24
@@ -1866,6 +1867,11 @@ fi
 
25
 
 
26
 # check for assembler specific support
 
27
 
 
28
+enabled arm && check_ld <<EOF && enable vfp_args
 
29
+__asm__ (".eabi_attribute 28, 1");
 
30
+int main(void) { return 0; }
 
31
+EOF
 
32
+
 
33
 enabled ppc && check_asm dcbzl '"dcbzl 0, 1"'
 
34
 enabled ppc && check_asm ppc4xx '"maclhw r10, r11, r12"'
 
35
 
 
36
diff --git a/libavcodec/arm/asm.S b/libavcodec/arm/asm.S
 
37
index 69d8348..087b279 100644
 
38
--- a/libavcodec/arm/asm.S
 
39
+++ b/libavcodec/arm/asm.S
 
40
@@ -45,3 +45,12 @@
 
41
         ldr             \rd, =\val
 
42
 #endif
 
43
         .endm
 
44
+
 
45
+#if HAVE_VFP_ARGS
 
46
+        .eabi_attribute 28, 1
 
47
+#   define VFP
 
48
+#   define NOVFP @
 
49
+#else
 
50
+#   define VFP   @
 
51
+#   define NOVFP
 
52
+#endif
 
53
-- 
 
54
1.6.3.3
 
55