~ubuntu-branches/ubuntu/lucid/libexif/lucid

« back to all changes in this revision

Viewing changes to debian/patches/60_fix_olympus_exif.patch.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Emmanuel Bouthenot
  • Date: 2009-04-19 17:53:15 UTC
  • mfrom: (6.1.1 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090419175315-5aiwj7jbm26srabc
Tags: 0.6.17-1
* Adopt the package within pkg-phototools:
  - Set the Maintainer to the group
  - Add Frederic Peters and myself as Uploaders.
  - Add Vcs-Browser and Vcs-Git fields accordingly.
* New upstream release:
  - remove patches merged upsteam:
    + 30_olympus_makernote.dpatch
    + 40_crash_looking_up_invalid_values.dpatch
    + 50_relibtoolize.dpatch
    + CVE-2007-6351.dpatch
    + CVE-2007-6352.dpatch
  - convert existing patches from dpatch to quilt.
  - Fix a bug while reading exif datas in some cases (Closes: #447907)
* Switch packaging to debhelper 7
* Update debian/control:
  - Drop duplicate section field for exif12
  - Bump Standards-Version to 3.8.1
  - Replace deprecated ${Source-Version} by ${binary:Version}
  - Enhance libexif-dev long description.
  - Add homepage field.
  - Add DM-Upload-Allowed field.
* Force remove of files not fully cleaned
* Remove empty doc files in libexif-dev.
* Update debian/copyright.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 60_fix_olympus_exif.patch.dpatch by  <sam@oberon-test>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad libexif-0.6.16~/libexif/olympus/exif-mnote-data-olympus.c libexif-0.6.16/libexif/olympus/exif-mnote-data-olympus.c
9
 
--- libexif-0.6.16~/libexif/olympus/exif-mnote-data-olympus.c   2007-05-11 07:22:44.000000000 +0100
10
 
+++ libexif-0.6.16/libexif/olympus/exif-mnote-data-olympus.c    2008-10-09 11:44:25.000000000 +0100
11
 
@@ -230,6 +230,15 @@
12
 
                else if (buf[o2 + 6 + 1] == 1)
13
 
                        n->order = EXIF_BYTE_ORDER_MOTOROLA;
14
 
                o2 += 8;
15
 
+               if (o2 >= buf_size) return;
16
 
+               c = exif_get_short (buf + o2, n->order);
17
 
+               if ((!(c & 0xFF)) && (c > 0x500)) {
18
 
+                       if (n->order == EXIF_BYTE_ORDER_INTEL) {
19
 
+                               n->order = EXIF_BYTE_ORDER_MOTOROLA;
20
 
+                       } else {
21
 
+                               n->order = EXIF_BYTE_ORDER_INTEL;
22
 
+                       }
23
 
+               }
24
 
 
25
 
        } else if (!memcmp (buf + o2, "OLYMPUS", 8)) {
26
 
                /* Olympus S760, S770 */