~ubuntu-branches/ubuntu/lucid/mupen64plus/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/122-default-optimisations.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sven Eckelmann
  • Date: 2009-09-28 15:23:17 UTC
  • Revision ID: james.westby@ubuntu.com-20090928152317-84y17o8hlh7batmw
Tags: 1.5+dfsg1-5
* debian/patches:
  - Change to dep3 patch tagging guidelines
  - Remove number before patches as order is given by debian/patches/series
  - Add gtk-open-filter.patch, Show files with .n64 and .v64 extension in
    filtered open file dialog (Closes: #546046)
  - Add noexecstack.patch, Don't enable executable stack by default
    (Closes: #547644)
  - Add fix_readpng.patch, Fix crash when loading png due to reordering
    optimizer
  - Add jttl_fix_romclosed.patch, Stop audio processing thread before freeing
    buffers to fix segfault during stop of emulation
  - Add rice_nodebug.patch, Don't enable excessive debug functionality in
    rice_video
  - Add interpreter_x86_fldcw.patch, Correctly set floating point control word
  - Add load-fpr-location.patch, Set register bank location when loading
    savestate

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 23d1fb825ba2dee370046f318ad91e9471b70479 Mon Sep 17 00:00:00 2001
2
 
From: Sven Eckelmann <sven.eckelmann@gmx.de>
3
 
Date: Tue, 8 Sep 2009 21:27:01 +0200
4
 
Subject: [PATCH] Don't override optimisations set by build environment
5
 
 
6
 
 
7
 
Signed-off-by: Sven Eckelmann <sven.eckelmann@gmx.de>
8
 
---
9
 
 pre.mk |   11 +++--------
10
 
 1 files changed, 3 insertions(+), 8 deletions(-)
11
 
 
12
 
diff --git a/pre.mk b/pre.mk
13
 
index 2c74ef5..d208340 100644
14
 
--- a/pre.mk
15
 
+++ b/pre.mk
16
 
@@ -305,15 +305,13 @@ else
17
 
 endif
18
 
 
19
 
 # set base CFLAGS and LDFLAGS
20
 
-CFLAGS += -pipe -O3 -ffast-math -funroll-loops -fexpensive-optimizations -fno-strict-aliasing
21
 
+CFLAGS += -fno-strict-aliasing
22
 
 CORE_LDFLAGS += -lz -lm -lpng -lfreetype -ldl
23
 
 
24
 
 # set special flags per-system
25
 
 ifeq ($(CPU), X86)
26
 
-  ifeq ($(ARCH), 64BITS)
27
 
-    CFLAGS += -march=athlon64
28
 
-  else
29
 
-    CFLAGS += -march=i686 -mtune=pentium-m -mmmx -msse
30
 
+  ifneq ($(ARCH), 64BITS)
31
 
+    CFLAGS += -mmmx -msse
32
 
     ifneq ($(PROFILE), 1)
33
 
       CFLAGS += -fomit-frame-pointer
34
 
     endif
35
 
@@ -324,9 +322,6 @@ ifeq ($(CPU), X86)
36
 
     LDFLAGS += -m32 -m elf_i386
37
 
   endif
38
 
 endif
39
 
-ifeq ($(CPU), PPC)
40
 
-  CFLAGS += -mcpu=powerpc
41
 
-endif
42
 
 ifeq ($(CPU_ENDIANNESS), BIG)
43
 
   CFLAGS += -D_BIG_ENDIAN
44
 
 endif
45
 
1.6.3.3
46