~ubuntu-branches/ubuntu/lucid/mupen64plus/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/system-libbz2.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sven Eckelmann
  • Date: 2009-09-28 15:23:17 UTC
  • Revision ID: james.westby@ubuntu.com-20090928152317-84y17o8hlh7batmw
Tags: 1.5+dfsg1-5
* debian/patches:
  - Change to dep3 patch tagging guidelines
  - Remove number before patches as order is given by debian/patches/series
  - Add gtk-open-filter.patch, Show files with .n64 and .v64 extension in
    filtered open file dialog (Closes: #546046)
  - Add noexecstack.patch, Don't enable executable stack by default
    (Closes: #547644)
  - Add fix_readpng.patch, Fix crash when loading png due to reordering
    optimizer
  - Add jttl_fix_romclosed.patch, Stop audio processing thread before freeing
    buffers to fix segfault during stop of emulation
  - Add rice_nodebug.patch, Don't enable excessive debug functionality in
    rice_video
  - Add interpreter_x86_fldcw.patch, Correctly set floating point control word
  - Add load-fpr-location.patch, Set register bank location when loading
    savestate

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Use libbz2 from system instead of buildin one
 
2
Bug: http://code.google.com/p/mupen64plus/issues/detail?id=235
 
3
Author: Sven Eckelmann <sven.eckelmann@gmx.de>
 
4
 
 
5
---
 
6
diff --git a/Makefile b/Makefile
 
7
index 3e468730d4f5a3315ee530f63008b7b80c346fdf..5f7abac0f1a02675ea84373e99c6e0b66c0e3773 100644
 
8
--- a/Makefile
 
9
+++ b/Makefile
 
10
@@ -110,13 +110,6 @@ OBJ_CORE = \
 
11
        main/savestates.o \
 
12
        main/zip/ioapi.o \
 
13
        main/zip/unzip.o \
 
14
-       main/bzip2/bzlib.o \
 
15
-       main/bzip2/crctable.o \
 
16
-       main/bzip2/decompress.o \
 
17
-       main/bzip2/compress.o \
 
18
-       main/bzip2/randtable.o \
 
19
-       main/bzip2/huffman.o \
 
20
-       main/bzip2/blocksort.o \
 
21
        main/lzma/buffer.o \
 
22
        main/lzma/io.o \
 
23
        main/lzma/main.o \
 
24
@@ -245,7 +238,7 @@ SHARE = $(shell grep CONFIG_PATH config.h | cut -d '"' -f 2)
 
25
 # set primary objects and libraries for all outputs
 
26
 ALL = mupen64plus $(PLUGINS)
 
27
 OBJECTS = $(OBJ_CORE) $(OBJ_DYNAREC) $(OBJ_OPENGL)
 
28
-LIBS = $(SDL_LIBS) $(LIBGL_LIBS)
 
29
+LIBS = $(SDL_LIBS) $(LIBGL_LIBS) -lbz2
 
30
 
 
31
 # add extra objects and libraries for selected options
 
32
 ifeq ($(DBG), 1)
 
33
@@ -342,7 +335,7 @@ endif
 
34
 clean-core:
 
35
 ifneq ($(OS), WINDOWS)
 
36
        $(RM_F) ./r4300/*.o ./r4300/x86/*.o ./r4300/x86_64/*.o ./memory/*.o ./debugger/*.o ./opengl/*.o
 
37
-       $(RM_F) ./main/*.o ./main/version.h ./main/zip/*.o ./main/bzip2/*.o ./main/lzma/*.o ./main/7zip/*.o ./main/gui_gtk/*.o ./main/gui_gtk/debugger/*.o
 
38
+       $(RM_F) ./main/*.o ./main/version.h ./main/zip/*.o ./main/lzma/*.o ./main/7zip/*.o ./main/gui_gtk/*.o ./main/gui_gtk/debugger/*.o
 
39
        $(RM_F) mupen64plus mupen64plus.desktop
 
40
        $(RM_F) main/gui_qt4/moc_* main/gui_qt4/ui_*.h main/gui_qt4/*.o main/gui_qt4/*.a main/gui_qt4/Makefile
 
41
        $(RM_F) translations/*.qm
 
42
diff --git a/main/rom.c b/main/rom.c
 
43
index 865451793ec78b18854993957ef96ab24b9ad52d..74c9643f861b1c8218baa8a00c9a17ec3106d695 100644
 
44
--- a/main/rom.c
 
45
+++ b/main/rom.c
 
46
@@ -28,7 +28,7 @@
 
47
 #include <zlib.h>
 
48
 
 
49
 #include "zip/unzip.h"
 
50
-#include "bzip2/bzlib.h"
 
51
+#include <bzlib.h>
 
52
 #include "lzma/lzmadec.h"
 
53
 #include "7zip/7zExtract.h"
 
54
 #include "7zip/7zCrc.h"