~ubuntu-branches/ubuntu/lucid/samba/lucid-security

« back to all changes in this revision

Viewing changes to debian/patches/security-CVE-2008-4314.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2009-01-28 02:35:42 UTC
  • mfrom: (0.25.12 lenny)
  • Revision ID: james.westby@ubuntu.com-20090128023542-6r5u95is6jppjasu
Tags: 2:3.2.5-4ubuntu1
* Merge from Debian unstable, remaining changes:
  + debian/patches/VERSION.patch:
    - setup SAMBA_VERSION_SUFFIX to Ubuntu.
  + debian/smb.conf:
    - add "(Samba, Ubuntu)" to server string.
    - comment out the default [homes] share, and add a comment about
      "valid users = %S" to show users how to restrict access to
      \\server\username to only username.
    - Set 'usershare allow guests', so that usershare admins are 
      allowed to create public shares in addition to authenticated
      ones.
    - add map to guest = Bad user, maps bad username to guest access. 
  + debian/samba.postinst:
    - When populating the new samabshare group, it is not an error
      if the user simply does not exist; test for this case and let
      the install continue instead of aborting.
  + debian/samba-common.config:
    - Do not change priority to high if dhclient3 is installed.
    - Use priority medium instead of high for the workgroup question.
  + debian/mksambapasswd.awk:
    - Do not add user with UID less than 1000 to smbpasswd.
  + debian/control:
    - Depend on lsb-base >= 3.2-14, which has the status_of_proc()
      function.
    - Make libpam-smbpasswd depend on libpam-runtime to allow 
      libpam-smbpasswd for auto-configuration.
    - Make libwbclient0 replace/conflict with hardy's likewise-open.
  + debian/samba.init:
    - Add a 'status' action.
  + debian/libpam-smbpass.pam-config, debian/libpam-smbpass.postinst,
    debian/libpam-smbpass.prerm, debian/libpam-smbpass.files,
    debian/rules:
    - Provide a config block for the new PAM framework to auto-configure
      itself
  + debian/rules:
    - enable "native" PIE hardening.
  + Add ufw integration:
    - Created debian/samba.uwf.profile
    - debian/rules, debian/samba.dirs, debian/samba.files: install
      profile
    - debian/control: have samba suggest ufw
  + debian/patches/last-char-truncation.patch:
    - Fix compatibility issue with NAS boxes still using Samba 2.2 and
      earlier.
  + debian/winbind.files:
    - include additional files
  + debian/winbind.init:
    - Add a PID variable and a 'status' action.
* Dropped changes:
  - don't worry about handling upgrades from feisty or edgy, since
    users should have upgraded to the hardy version first so this
    transition is now finished.
* Fixes LP: #264943 and LP: #286119.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#
2
 
# Description: Fix potential arbitrary memory leak and crash via secondary
3
 
#              trans, trans2 and nttrans requests.
4
 
#
5
 
Index: samba-3.2.4/source/smbd/ipc.c
6
 
===================================================================
7
 
--- samba-3.2.4.orig/source/smbd/ipc.c  2008-11-21 14:47:49.000000000 -0500
8
 
+++ samba-3.2.4/source/smbd/ipc.c       2008-11-21 14:48:22.000000000 -0500
9
 
@@ -764,10 +764,10 @@
10
 
                        goto bad_param;
11
 
                }
12
 
 
13
 
-               if (ddisp > av_size ||
14
 
+               if (doff > av_size ||
15
 
                                dcnt > av_size ||
16
 
-                               ddisp+dcnt > av_size ||
17
 
-                               ddisp+dcnt < ddisp) {
18
 
+                               doff+dcnt > av_size ||
19
 
+                               doff+dcnt < doff) {
20
 
                        goto bad_param;
21
 
                }
22
 
 
23
 
Index: samba-3.2.4/source/smbd/nttrans.c
24
 
===================================================================
25
 
--- samba-3.2.4.orig/source/smbd/nttrans.c      2008-11-21 14:47:53.000000000 -0500
26
 
+++ samba-3.2.4/source/smbd/nttrans.c   2008-11-21 14:48:22.000000000 -0500
27
 
@@ -2853,10 +2853,10 @@
28
 
                        goto bad_param;
29
 
                }
30
 
 
31
 
-               if (ddisp > av_size ||
32
 
+               if (doff > av_size ||
33
 
                                dcnt > av_size ||
34
 
-                               ddisp+dcnt > av_size ||
35
 
-                               ddisp+dcnt < ddisp) {
36
 
+                               doff+dcnt > av_size ||
37
 
+                               doff+dcnt < doff) {
38
 
                        goto bad_param;
39
 
                }
40
 
 
41
 
Index: samba-3.2.4/source/smbd/trans2.c
42
 
===================================================================
43
 
--- samba-3.2.4.orig/source/smbd/trans2.c       2008-11-21 14:47:58.000000000 -0500
44
 
+++ samba-3.2.4/source/smbd/trans2.c    2008-11-21 14:48:22.000000000 -0500
45
 
@@ -7783,10 +7783,10 @@
46
 
                        goto bad_param;
47
 
                }
48
 
 
49
 
-               if (ddisp > av_size ||
50
 
+               if (doff > av_size ||
51
 
                                dcnt > av_size ||
52
 
-                               ddisp+dcnt > av_size ||
53
 
-                               ddisp+dcnt < ddisp) {
54
 
+                               doff+dcnt > av_size ||
55
 
+                               doff+dcnt < doff) {
56
 
                        goto bad_param;
57
 
                }
58