~ubuntu-branches/ubuntu/maverick/glade-3/maverick

« back to all changes in this revision

Viewing changes to debian/patches/02_rename_crash.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2008-06-20 14:43:35 UTC
  • mfrom: (1.1.17 lenny)
  • Revision ID: james.westby@ubuntu.com-20080620144335-mcazxmarzccdgd2t
Tags: 3.4.5-3ubuntu1
* Sync on Debian
* Version binaries so they don't conflict with the previous glade version
* debian/control.in:
  - don't use conflict on glade
  - updated binary naming
  - updated maintainer information
  - use replaces required
* debian/rules:
  - correctly install icons
  - updated for the ubuntu binaries naming
  - use gnome.mk so the icon cache and translations template are updated

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: gladeui/glade-base-editor.c
 
2
===================================================================
 
3
--- gladeui/glade-base-editor.c (revision 1826)
 
4
+++ gladeui/glade-base-editor.c (working copy)
 
5
@@ -377,7 +377,7 @@
 
6
 glade_base_editor_update_properties_idle (gpointer data)
 
7
 {
 
8
        GladeBaseEditor *editor = (GladeBaseEditor *)data;
 
9
-       glade_base_editor_treeview_cursor_changed (NULL, editor);
 
10
+       glade_base_editor_treeview_cursor_changed (editor->priv->treeview, editor);
 
11
        editor->priv->properties_idle = 0;
 
12
        return FALSE;
 
13
 }
 
14
@@ -1146,7 +1146,7 @@
 
15
        }
 
16
 
 
17
        /* Set the name */
 
18
-       glade_widget_set_name (gchild_new, name);
 
19
+       glade_command_set_name (gchild_new, name);
 
20
        
 
21
        if (GTK_IS_WIDGET (child_new))
 
22
                gtk_widget_show_all (GTK_WIDGET (child_new));
 
23
Index: gladeui/glade-project.c
 
24
===================================================================
 
25
--- gladeui/glade-project.c     (revision 1826)
 
26
+++ gladeui/glade-project.c     (working copy)
 
27
@@ -1915,6 +1915,7 @@
 
28
 
 
29
        g_return_if_fail (GLADE_IS_PROJECT (project));
 
30
        g_return_if_fail (GLADE_IS_WIDGET (glade_widget));
 
31
+       g_return_if_fail (widget_name);
 
32
 
 
33
        do
 
34
        {