~ubuntu-branches/ubuntu/maverick/glade-3/maverick

« back to all changes in this revision

Viewing changes to debian/patches/99_ltmain_as-needed.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2008-06-20 14:43:35 UTC
  • mfrom: (1.1.17 lenny)
  • Revision ID: james.westby@ubuntu.com-20080620144335-mcazxmarzccdgd2t
Tags: 3.4.5-3ubuntu1
* Sync on Debian
* Version binaries so they don't conflict with the previous glade version
* debian/control.in:
  - don't use conflict on glade
  - updated binary naming
  - updated maintainer information
  - use replaces required
* debian/rules:
  - correctly install icons
  - updated for the ubuntu binaries naming
  - use gnome.mk so the icon cache and translations template are updated

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur -x '*.orig' -x '*~' glade-3-3.4.1/ltmain.sh glade-3-3.4.1.new/ltmain.sh
2
 
--- glade-3-3.4.1/ltmain.sh     2007-11-27 21:09:41.000000000 +0100
3
 
+++ glade-3-3.4.1.new/ltmain.sh 2008-01-08 13:13:34.000000000 +0100
 
1
--- ltmain.sh~  2007-11-28 04:09:41.000000000 +0800
 
2
+++ ltmain.sh   2007-12-19 21:19:06.000000000 +0800
4
3
@@ -1794,6 +1794,11 @@
5
4
        arg=`$echo "X$arg" | $Xsed -e "s/^ //"`
6
5
        ;;
17
16
        lib=
18
17
        found=no
19
18
        case $deplib in
20
 
+       -Wl,--as-needed)
21
 
+         if test "$linkmode,$pass" = "prog,link"; then
22
 
+           compile_deplibs="$deplib $compile_deplibs"
23
 
+           finalize_deplibs="$deplib $finalize_deplibs"
24
 
+         else
25
 
+           deplibs="$deplib $deplibs"
26
 
+         fi
27
 
+         continue
28
 
+         ;;
 
19
+       -Wl,--as-needed)
 
20
+         if test "$linkmode,$pass" = "prog,link"; then
 
21
+           compile_deplibs="$deplib $compile_deplibs"
 
22
+           finalize_deplibs="$deplib $finalize_deplibs"
 
23
+         else
 
24
+           deplibs="$deplib $deplibs"
 
25
+         fi
 
26
+         continue
 
27
+         ;;
29
28
        -mt|-mthreads|-kthread|-Kthread|-pthread|-pthreads|--thread-safe|-threads)
30
29
          if test "$linkmode,$pass" = "prog,link"; then
31
30
            compile_deplibs="$deplib $compile_deplibs"