~ubuntu-branches/ubuntu/maverick/packagekit/maverick-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix_typo.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Heinlein
  • Date: 2009-08-25 13:03:26 UTC
  • mfrom: (1.1.9 upstream)
  • Revision ID: james.westby@ubuntu.com-20090825130326-jrky8pfx0ukz0lib
Tags: 0.4.9+20090825-0ubuntu1
* New upstream snapshot provding a lot of APT backend improvements:
  - Allow to install updates which require the installation of additional
    packages. Updates depending on the removal of a package are still
    blocked (LP: #342671, LP: #374011, LP: #374011)
  - Warn about the installation of untrusted package (LP: #256245)
  - Don't crash in APT post update hook if system D-Bus daemon isn't 
    running (LP: #388623)
  - Don't try to estimate a download progress during cache updating, since
    APT reports only a forth- and backwards running progress. (LP: #348053)
  - Support for python-apt 0.7.12 (LP: #415993)
  - Translated package descriptions
* debian/patches:
  - Remove ignore_packages_in_conffile (Merged upstream)
  - Remove fix_typo (Merged upstream)
  - Add fix_unicode: Handle the encoding messages via stdin/stdout correctly
    (LP: #396513)
  - Add fix_unicode_debfile: Convert the path of the local file which
    should be installed to the correct encoding (LP: #347327)
* debian/libpackagekit-qt-dev.install: Fix install location of CMake module.
  Thanks to Sveinung Kvilhaugsvik (LP: #345706)
* debian/control: Fix spelling of Qt. Thanks to Sveinung Kvilhaugsvik
  (LP: #378419)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Origin: vendor
2
 
Bug-Ubuntu: https://bugs.launchpad.net/bugs/393326
3
 
Forwarded: not-needed
4
 
Author: Koray Eyinc <korayeyinc@gmail.com>
5
 
Reviewed-by: James Westby <james.westby@ubuntu.com>
6
 
Description: Fix a simple typo that causes crashes
7
 
 Not forwarded as the code doesn't exist in current upstream
8
 
 git.
9
 
 
10
 
=== modified file 'backends/apt/aptBackend.py'
11
 
--- a/backends/apt/aptBackend.py        2009-06-10 22:12:47 +0000
12
 
+++ b/backends/apt/aptBackend.py        2009-07-04 19:52:27 +0000
13
 
@@ -1295,7 +1295,7 @@
14
 
         Implement the apt2-get-requires functionality
15
 
         """
16
 
         pklog.info("Get requires (%s,%s,%s)" % (filter, ids, recursive_text))
17
 
-        recursive = text_to_bool(rescursive_text)
18
 
+        recursive = text_to_bool(recursive_text)
19
 
         #FIXME: recursive is not yet implemented
20
 
         if recursive == True:
21
 
             pklog.warn("Recursive dependencies are not implemented")
22