~ubuntu-branches/ubuntu/maverick/scribus-ng/maverick-backports

« back to all changes in this revision

Viewing changes to debian/patches/03_cmake_rpath.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Oleksandr Moskalenko
  • Date: 2007-08-11 17:41:51 UTC
  • mfrom: (0.1.1 upstream) (4.1.2 feisty)
  • Revision ID: james.westby@ubuntu.com-20070811174151-tmkgjvjuc0mtk8ul
Tags: 1.3.4.dfsg+svn20071115-1
* Upstream svn update (Closes: #447480, #448949).
* debian/NEWS: Added a note for users wanting stable Scribus to switch to
  the "scribus" package (Closes: #427638).
* debian/watch: Updated the watch regex to properly track sourceforge
  releases for this branch (Closes: #449700).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 03_cmake_rpath.dpatch by Oleksandr Moskalenko <malex@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: CMakeLists.txt rpath mode selection
 
6
 
 
7
@DPATCH@
 
8
 
 
9
--- scribus-ng-1.3.3.7.dfsg/CMakeLists.txt      2007-01-16 12:17:39.000000000 -0700
 
10
+++ CMakeLists.txt.rpath        2007-01-16 12:21:42.000000000 -0700
 
11
@@ -7,7 +7,13 @@
 
12
 SET(CMAKE_COLOR_MAKEFILE ON)
 
13
 SET(CMAKE_VERBOSE_MAKEFILE ON)
 
14
 SET(CMAKE_INCLUDE_CURRENT_DIR TRUE)
 
15
+IF(CMAKE_SKIP_RPATH)
 
16
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
 
17
+MESSAGE("RPATH: ${CMAKE_BUILD_WITH_INSTALL_RPATH}")
 
18
+ELSE(CMAKE_SKIP_RPATH)
 
19
 SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
 
20
+MESSAGE("RPATH: ${CMAKE_BUILD_WITH_INSTALL_RPATH}")
 
21
+ENDIF(CMAKE_SKIP_RPATH)
 
22
 #SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
 
23
 #SET(CMAKE_SKIP_RPATH:BOOL NO)
 
24
 SET(CMAKE_SKIP_RULE_DEPENDENCY TRUE)