~ubuntu-branches/ubuntu/maverick/speech-tools/maverick

« back to all changes in this revision

Viewing changes to debian/patches/config_config.diff

  • Committer: Bazaar Package Importer
  • Author(s): Kartik Mistry, Kumar Appaiah, Kartik Mistry
  • Date: 2007-11-19 17:39:39 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20071119173939-l5zuh2waxmrel31x
Tags: 1:1.2.96~beta-1
[Kumar Appaiah]
* Long awaited new upstream version (Closes: #437682)
* debian/patches:
  + Split all patches, and use quilt for patch management
  + Use latest config.guess, config.sub
* Minor manpage description fix
* debian/rules:
  + Fix old autoconf files, using autotools-dev
  + Find versions using debian/get_versions.sh, instead of hard coding

[Kartik Mistry]
* Added debian/watch file from Kumar
* debian/control:
  + Added homepage entry
  + Added Kumar Appaiah as co-maintainer list
  + Added XS-Dm-Upload-Allowed: yes to allow Debian-Maintainer upload
* debian/copyright: moved copyright out of license section
* debian/manpage.1: fixed lintian warning
* debian/rules: includes base_class/*.cc which is badly needed for
  festival compilation

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- speech-tools-1.2.3.orig/config/config
 
2
+++ speech-tools-1.2.3/config/config
 
3
@@ -0,0 +1,172 @@
 
4
+########################################################-*-mode:Makefile-*-
 
5
+##                                                                       ##
 
6
+##  Edinburgh Speech Tools: local configuration file                     ##
 
7
+##                                                                       ##
 
8
+###########################################################################
 
9
+##
 
10
+##  Specific config file for local installation
 
11
+##
 
12
+
 
13
+###########################################################################
 
14
+## Where the speech_tools tree will be installed.
 
15
+## 
 
16
+## The default is that the speech_tools will remain where it is compiled.
 
17
+##
 
18
+## You may need to set this explicitly if automounter or NFS
 
19
+## side effects cause problems
 
20
+
 
21
+EST_HOME := $(shell (cd $(EST); pwd))
 
22
+
 
23
+###########################################################################
 
24
+## System type. 
 
25
+##
 
26
+## The system will attempt to determine this, but if it is wrong you may
 
27
+## need to set it explicitly. The definitions are in 
 
28
+## systems/$(SYSTEM_TYPE).mak
 
29
+##
 
30
+## Format: machine _ os osrev
 
31
+## 
 
32
+## Examples: sparc_SunOS5 intel_Linux2.0
 
33
+
 
34
+SYSTEM_TYPE=unknown_DebianGNULinux
 
35
+
 
36
+###########################################################################
 
37
+## Compiler.
 
38
+## The definitions are in compilers/$(COMPILER).mak
 
39
+## Examples: gcc suncc egcs gcc28
 
40
+
 
41
+COMPILER=gcc295
 
42
+
 
43
+###########################################################################
 
44
+## Java system to use if you include the Java interface.
 
45
+## Examples jdk
 
46
+
 
47
+JAVA_COMPILER=jdk
 
48
+
 
49
+###########################################################################
 
50
+## Pre defined configurations (for directory locations, setup peculiarities
 
51
+## etc.)
 
52
+##
 
53
+## Examples: default cstr rjc
 
54
+
 
55
+CONFIGURATION = 
 
56
+
 
57
+###########################################################################
 
58
+## Compilation options.
 
59
+##
 
60
+## OPTIMISE=4 will turn off DEBUG
 
61
+
 
62
+OPTIMISE=3
 
63
+WARN=1
 
64
+# VERBOSE=1
 
65
+DEBUG=1
 
66
+# PROFILE=gprof
 
67
+SHARED=2
 
68
+
 
69
+## Directory specific selections which override the above
 
70
+
 
71
+OPTIMISE_sigpr = 3
 
72
+
 
73
+###########################################################################
 
74
+## Feature selection.
 
75
+##
 
76
+## Select modules to include.
 
77
+
 
78
+## AUDIO
 
79
+## various audio devices are supported directly but you can always
 
80
+## specify a program to play files in a desired format.
 
81
+
 
82
+## NCD's network audio system, This is recommended.
 
83
+# INCLUDE_MODULES += NAS_AUDIO
 
84
+
 
85
+## Elightenment Sound Demon, for KDE etc.
 
86
+INCLUDE_MODULES += ESD_AUDIO
 
87
+
 
88
+## Native audio for your platform (sun, linux, freebsd, irix, windows)
 
89
+INCLUDE_MODULES += NATIVE_AUDIO
 
90
+
 
91
+## Special code to run Windows MPLAYER
 
92
+# INCLUDE_MODULES += MPLAYER_AUDIO
 
93
+
 
94
+## USER INTERFACE
 
95
+
 
96
+## Command-line editing. This option gives command line editing and history.
 
97
+## It may not work under all systems, so may be optionally omitted.
 
98
+INCLUDE_MODULES += EDITLINE
 
99
+
 
100
+# speech recognition
 
101
+#INCLUDE_MODULES += ASR
 
102
+
 
103
+
 
104
+## Scheme
 
105
+
 
106
+## Scheme In One Defun interpreter and data structures
 
107
+INCLUDE_MODULES += SIOD
 
108
+
 
109
+## The following subsystems depend on the Scheme subsystem and so
 
110
+## must be removed if Scheme is not included
 
111
+
 
112
+INCLUDE_MODULES += WAGON
 
113
+INCLUDE_MODULES += SCFG
 
114
+INCLUDE_MODULES += WFST
 
115
+INCLUDE_MODULES += OLS
 
116
+
 
117
+## Java
 
118
+
 
119
+
 
120
+## Define this to include the pure Java code
 
121
+# INCLUDE_MODULES += JAVA
 
122
+# JAVA_HOME = PUT_SOMETHING_HERE
 
123
+
 
124
+## Define this to compile the Java interface to the EST classes. You
 
125
+## need to compile with the SHARED option above. This is required for
 
126
+## fringe.
 
127
+# INCLUDE_MODULES += JAVA_CPP
 
128
+
 
129
+## Define this to have the Java code use the Java Media API to
 
130
+## play sounds etc.
 
131
+# INCLUDE_MODULES += JAVA_MEDIA
 
132
+# JMF_HOME = PUT_SOMETHING_HERE
 
133
+
 
134
+## Richard Tobin's RXP XML parser.
 
135
+INCLUDE_MODULES += RXP
 
136
+
 
137
+## Debugging, You should probably ony do one or the other of these.
 
138
+
 
139
+## Efence protected malloc library to catch memory errors
 
140
+# INCLUDE_MODULES += EFENCE
 
141
+
 
142
+## Dmalloc, another chekcing malloc library
 
143
+# INCLUDE_MODULES += DMALLOC
 
144
+
 
145
+## Additional subsystems to include should be listed here.
 
146
+
 
147
+ALSO_INCLUDE=
 
148
+
 
149
+## Turn this on to compile all known modules. This is intended for
 
150
+## portability testing.
 
151
+
 
152
+# INCLUDE_EVERYTHING=1
 
153
+
 
154
+
 
155
+###########################################################################
 
156
+## Now include the settings
 
157
+
 
158
+include $(EST)/config/systems/$(SYSTEM_TYPE).mak
 
159
+
 
160
+include $(EST)/config/compilers/$(COMPILER).mak
 
161
+
 
162
+ifneq ($(JAVA_COMPILER),none)
 
163
+    include $(EST)/config/compilers/$(JAVA_COMPILER).mak
 
164
+endif
 
165
+
 
166
+ifneq ($(CONFIGURATION),)
 
167
+    include $(CONFIGURATION:%=$(EST)/config/configs/%.mak)
 
168
+endif
 
169
+
 
170
+###########################################################################
 
171
+##
 
172
+## Any settings you need to describe how your system differs from the
 
173
+## assumed defaults should go below. See config/ReadMe for a description
 
174
+## of the most common things you might need.
 
175
+