~ubuntu-branches/ubuntu/maverick/speech-tools/maverick

« back to all changes in this revision

Viewing changes to debian/patches/speech_class_EST_track_aux.cc.diff

  • Committer: Bazaar Package Importer
  • Author(s): Kartik Mistry, Kumar Appaiah, Kartik Mistry
  • Date: 2007-11-19 17:39:39 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20071119173939-l5zuh2waxmrel31x
Tags: 1:1.2.96~beta-1
[Kumar Appaiah]
* Long awaited new upstream version (Closes: #437682)
* debian/patches:
  + Split all patches, and use quilt for patch management
  + Use latest config.guess, config.sub
* Minor manpage description fix
* debian/rules:
  + Fix old autoconf files, using autotools-dev
  + Find versions using debian/get_versions.sh, instead of hard coding

[Kartik Mistry]
* Added debian/watch file from Kumar
* debian/control:
  + Added homepage entry
  + Added Kumar Appaiah as co-maintainer list
  + Added XS-Dm-Upload-Allowed: yes to allow Debian-Maintainer upload
* debian/copyright: moved copyright out of license section
* debian/manpage.1: fixed lintian warning
* debian/rules: includes base_class/*.cc which is badly needed for
  festival compilation

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- speech-tools-1.2.3.orig/speech_class/EST_track_aux.cc
 
2
+++ speech-tools-1.2.3/speech_class/EST_track_aux.cc
 
3
@@ -351,7 +351,7 @@
 
4
     mean /= n;
 
5
     
 
6
     for (i = 0, var = 0.0; i < tr.num_frames(); ++i)
 
7
-       var += tr.track_break(i) ? 0.0 : pow(tr.a(i, channel) - mean, 2.0);
 
8
+       var += tr.track_break(i) ? 0.0 : pow(tr.a(i, channel) - mean, (float)2.0);
 
9
     
 
10
     var /= n;
 
11
     sd = sqrt(var);
 
12
@@ -369,7 +369,7 @@
 
13
     
 
14
     for (i = 0; i < size; ++i)
 
15
        if (a.val(i) && b.val(i))
 
16
-           sum += pow((a.a(i, channel) - b.a(i, channel)), 2.0);
 
17
+           sum += pow((a.a(i, channel) - b.a(i, channel)), (float)2.0);
 
18
     
 
19
     sum = sqrt(sum / size);
 
20
     return sum;
 
21
@@ -461,7 +461,7 @@
 
22
     for (p = tl.head(); p; p = next(p))
 
23
        for (i = 0; i < tl(p).num_frames(); ++i)
 
24
            if (!tl(p).track_break(i))
 
25
-               var +=  pow(tl(p).a(i, channel) - mean, 2.0);
 
26
+               var +=  pow(tl(p).a(i, channel) - mean, (float)2.0);
 
27
 
 
28
     var /= n;
 
29
     sd = sqrt(var);