~ubuntu-branches/ubuntu/natty/expect/natty

« back to all changes in this revision

Viewing changes to debian/patches/05-makefile-soname.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2009-10-23 12:24:40 UTC
  • mfrom: (5.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20091023122440-5uujs2py5bx5v7vs
* Added buid conflict with autoconf2.13 because autoconf 2.50 or newer is
  required to process configure.in template.
* Fixed building with the current config.sub and config.guess from
  autotools-dev package (closes: #551332).
* Fixed cleaning after build is done.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: Mike Markley <mike@markley.org>
 
1
Author: Sergei Golovan <sgolovan@debian.org>
2
2
Description: Adds '-soname' to the Makefile.
3
3
 
4
 
diff -Naurp expect.orig/Makefile.in expect/Makefile.in
5
 
--- expect.orig/Makefile.in     2009-08-03 06:58:30.000000000 +0000
6
 
+++ expect/Makefile.in  2009-08-03 08:34:51.000000000 +0000
7
 
@@ -413,7 +413,7 @@ $(EXP_UNSHARED_LIB_FILE): $(OFILES)
8
 
 expect-shared-lib-file :: $(EXP_SHARED_LIB_FILE)
9
 
 $(EXP_SHARED_LIB_FILE): $(OFILES)
10
 
        -rm -f $(EXP_SHARED_LIB_FILE)
11
 
-       @TCL_SHLIB_LD@ -o $(EXP_SHARED_LIB_FILE) $(SHARED_OFILES) @EXP_LD_SEARCH_FLAGS@ @EXP_SHLIB_LD_LIBS@
12
 
+       @TCL_SHLIB_LD@ -o $(EXP_SHARED_LIB_FILE) $(SHARED_OFILES) @EXP_LD_SEARCH_FLAGS@ @EXP_SHLIB_LD_LIBS@ -Wl,-soname,$(SONAME)
13
 
 
14
 
 .PHONY: install-info install info
15
 
 install-info:
 
4
--- expect.orig/Makefile.in
 
5
+++ expect/Makefile.in
 
6
@@ -290,7 +290,7 @@
 
7
 
 
8
 $(PKG_LIB_FILE): $(PKG_OBJECTS)
 
9
        -rm -f $(PKG_LIB_FILE)
 
10
-       ${MAKE_LIB}
 
11
+       ${MAKE_LIB} -Wl,-soname,$(SONAME)
 
12
        $(RANLIB) $(PKG_LIB_FILE)
 
13
 
 
14
 $(PKG_STUB_LIB_FILE): $(PKG_STUB_OBJECTS)