~ubuntu-branches/ubuntu/natty/expect/natty

« back to all changes in this revision

Viewing changes to debian/patches/15-comments.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2009-10-23 12:24:40 UTC
  • mfrom: (5.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20091023122440-5uujs2py5bx5v7vs
* Added buid conflict with autoconf2.13 because autoconf 2.50 or newer is
  required to process configure.in template.
* Fixed building with the current config.sub and config.guess from
  autotools-dev package (closes: #551332).
* Fixed cleaning after build is done.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Author: n/a
2
2
Description: Fix header comments.
3
3
 
4
 
diff -Naurp expect.orig/expect_cf.h.in expect/expect_cf.h.in
5
 
--- expect.orig/expect_cf.h.in  2009-08-03 06:58:30.000000000 +0000
6
 
+++ expect/expect_cf.h.in       2009-08-03 08:58:57.000000000 +0000
7
 
@@ -4,7 +4,8 @@
8
 
 #ifndef __EXPECT_CF_H__
9
 
 #define __EXPECT_CF_H__
10
 
 
11
 
-#undef NO_STDLIB_H             /* Tcl requires this name */
12
 
+/* Tcl requires this name */
13
 
+#undef NO_STDLIB_H
14
 
 #undef NO_UNION_WAIT
15
 
 #undef HAVE_STDARG_H
16
 
 #undef HAVE_VARARGS_H
17
 
@@ -12,12 +13,18 @@
18
 
 #undef HAVE_SYSCONF_H
19
 
 #undef HAVE_SYS_FCNTL_H
20
 
 #undef HAVE_SYS_WAIT_H
21
 
-#undef HAVE_SYS_BSDTYPES_H     /* nice ISC special */
22
 
-#undef HAVE_SYS_SELECT_H       /* nice ISC special */
23
 
-#undef HAVE_SYS_TIME_H         /* nice ISC special */
24
 
-#undef HAVE_SYS_PTEM_H         /* SCO needs this for window size */
25
 
-#undef HAVE_STRREDIR_H         /* Solaris needs this for console redir */
26
 
-#undef HAVE_STRPTY_H           /* old-style Dynix ptys need this */
27
 
+/* nice ISC special */
28
 
+#undef HAVE_SYS_BSDTYPES_H
29
 
+/* nice ISC special */
30
 
+#undef HAVE_SYS_SELECT_H
31
 
+/* nice ISC special */
32
 
+#undef HAVE_SYS_TIME_H
33
 
+/* SCO needs this for window size */
34
 
+#undef HAVE_SYS_PTEM_H
35
 
+/* Solaris needs this for console redir */
36
 
+#undef HAVE_STRREDIR_H
37
 
+/* old-style Dynix ptys need this */
38
 
+#undef HAVE_STRPTY_H
39
 
 #undef HAVE_UNISTD_H
40
 
 #undef HAVE_SYSMACROS_H
41
 
 #undef HAVE_INTTYPES_H
42
 
@@ -26,8 +33,10 @@
43
 
 
44
 
 #undef pid_t
45
 
 #undef RETSIGTYPE
46
 
-#undef TIME_WITH_SYS_TIME      /* ok to include both time.h and sys/time.h */
47
 
-#undef SETPGRP_VOID            /* if setpgrp takes 0 args */
48
 
+/* ok to include both time.h and sys/time.h */
49
 
+#undef TIME_WITH_SYS_TIME
50
 
+/* if setpgrp takes 0 args */
51
 
+#undef SETPGRP_VOID
52
 
 
53
 
 /*
54
 
  * This section is for compile macros needed by
55
 
@@ -42,7 +51,8 @@
56
 
 #undef SIMPLE_EVENT
57
 
 #undef HAVE_STRFTIME
58
 
 #undef HAVE_MEMMOVE
59
 
-#undef HAVE_TIMEZONE           /* timezone() a la Pyramid */
60
 
+/* timezone() a la Pyramid */
61
 
+#undef HAVE_TIMEZONE
62
 
 #undef HAVE_SIGLONGJMP
63
 
 #undef HAVE_STRCHR
64
 
 
65
4
diff -Naurp expect.orig/tcldbgcf.h.in expect/tcldbgcf.h.in
66
5
--- expect.orig/tcldbgcf.h.in   2009-08-03 06:58:30.000000000 +0000
67
6
+++ expect/tcldbgcf.h.in        2009-08-03 08:58:57.000000000 +0000