~ubuntu-branches/ubuntu/natty/php5/natty

« back to all changes in this revision

Viewing changes to debian/patches/bug52573.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2011-01-07 22:44:56 UTC
  • mfrom: (0.3.17 sid)
  • Revision ID: package-import@ubuntu.com-20110107224456-rfnz8n46skjgr7nm
Tags: 5.3.3-7ubuntu1
* Merge from debian unstable.  Remaining changes:
  - debian/control:
    * Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
    * Dropped libmysqlclient15-dev, build against mysql 5.1.
    * Dropped libcurl-dev not in the archive.
    * Suggest php5-suhosin rather than recommends.
    * Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions 
      already in universe.
    * Dropped libonig-dev and libqgdbm since its in universe. (will be re-added in lucid+1)
    * Dropped locales-all.
  - modulelist: Drop imap, interbase, sybase, and mcrypt.
  - debian/rules:
    * Dropped building of mcrypt, imap, and interbase.
    * Install apport hook for php5.
    * stop mysql instance on clean just in case we failed in tests
  - Dropped debian/patches/fix-upstream-bug53632.patch, used debian's instead.
  - Dropped debian/patches/mssql-fix-segfault.patch, use debian's instead.
  - debian/patches/configure-as-needed.patch. Work around suspicious
    configure macros to fix a build failure with --as-needed
  - debian/patches/php52389-pgsql-segfault.patch: removing, causes error
    handling to fail.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/ext/spl/spl_directory.c   2010/08/10 21:52:14     302084
 
2
+++ b/ext/spl/spl_directory.c   2010/08/10 22:37:24     302085
 
3
@@ -1862,7 +1862,11 @@
 
4
 
 
5
        result = zend_call_function(&fci, &fcic TSRMLS_CC);
 
6
        
 
7
-       ZVAL_ZVAL(return_value, retval, 1, 1);
 
8
+       if (result == FAILURE) {
 
9
+               RETVAL_FALSE;
 
10
+       } else {
 
11
+               ZVAL_ZVAL(return_value, retval, 1, 1);
 
12
+       }
 
13
 
 
14
        efree(params);
 
15
        return result;