~ubuntu-branches/ubuntu/natty/php5/natty

« back to all changes in this revision

Viewing changes to debian/patches/php-5.3.4-ini.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short
  • Date: 2011-01-07 22:44:56 UTC
  • mfrom: (0.3.17 sid)
  • Revision ID: package-import@ubuntu.com-20110107224456-rfnz8n46skjgr7nm
Tags: 5.3.3-7ubuntu1
* Merge from debian unstable.  Remaining changes:
  - debian/control:
    * Dropped firebird2.1-dev, libc-client-dev, libmcrypt-dev as it is in universe.
    * Dropped libmysqlclient15-dev, build against mysql 5.1.
    * Dropped libcurl-dev not in the archive.
    * Suggest php5-suhosin rather than recommends.
    * Dropped php5-imap, php5-interbase, php5-mcrypt since we have versions 
      already in universe.
    * Dropped libonig-dev and libqgdbm since its in universe. (will be re-added in lucid+1)
    * Dropped locales-all.
  - modulelist: Drop imap, interbase, sybase, and mcrypt.
  - debian/rules:
    * Dropped building of mcrypt, imap, and interbase.
    * Install apport hook for php5.
    * stop mysql instance on clean just in case we failed in tests
  - Dropped debian/patches/fix-upstream-bug53632.patch, used debian's instead.
  - Dropped debian/patches/mssql-fix-segfault.patch, use debian's instead.
  - debian/patches/configure-as-needed.patch. Work around suspicious
    configure macros to fix a build failure with --as-needed
  - debian/patches/php52389-pgsql-segfault.patch: removing, causes error
    handling to fail.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/main/php_ini.c
 
2
+++ b/main/php_ini.c
 
3
@@ -201,6 +201,7 @@ PHPAPI void config_zval_dtor(zval *zvalu
 
4
 /* Reset / free active_ini_sectin global */
 
5
 #define RESET_ACTIVE_INI_HASH() do { \
 
6
        active_ini_hash = NULL;          \
 
7
+       is_special_section = 0;          \
 
8
 } while (0)
 
9
 /* }}} */
 
10
 
 
11
@@ -628,9 +629,6 @@ int php_init_config(TSRMLS_D)
 
12
                zend_llist_element *element;
 
13
                int l, total_l = 0;
 
14
 
 
15
-               /* Reset active ini section */
 
16
-               RESET_ACTIVE_INI_HASH();
 
17
-
 
18
                if ((ndir = php_scandir(php_ini_scanned_path, &namelist, 0, php_alphasort)) > 0) {
 
19
                        zend_llist_init(&scanned_ini_list, sizeof(char *), (llist_dtor_func_t) free_estring, 1);
 
20
                        memset(&fh, 0, sizeof(fh));
 
21
@@ -642,6 +640,9 @@ int php_init_config(TSRMLS_D)
 
22
                                        free(namelist[i]);
 
23
                                        continue;
 
24
                                }
 
25
+                               /* Reset active ini section */
 
26
+                               RESET_ACTIVE_INI_HASH();
 
27
+
 
28
                                if (IS_SLASH(php_ini_scanned_path[php_ini_scanned_path_len - 1])) {
 
29
                                        snprintf(ini_file, MAXPATHLEN, "%s%s", php_ini_scanned_path, namelist[i]->d_name);
 
30
                                } else {