~ubuntu-branches/ubuntu/natty/python3.1/natty-security

« back to all changes in this revision

Viewing changes to debian/patches/cthreads.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2010-07-06 16:52:42 UTC
  • mfrom: (1.2.1 upstream) (2.1.11 sid)
  • Revision ID: james.westby@ubuntu.com-20100706165242-2xv4i019r3et6c0j
Tags: 3.1.2+20100706-1ubuntu1
* Merge with Debian; remaining changes:
  - Regenerate the control file.
  - Add debian/patches/overwrite-semaphore-check for Lucid buildds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
# DP: Remove cthreads detection
4
 
 
5
 
dir=
6
 
if [ $# -eq 3 -a "$2" = '-d' ]; then
7
 
    pdir="-d $3"
8
 
    dir="$3/"
9
 
elif [ $# -ne 1 ]; then
10
 
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
11
 
    exit 1
12
 
fi
13
 
case "$1" in
14
 
    -patch)
15
 
        patch $pdir -f --no-backup-if-mismatch -p0 < $0
16
 
        autoconf
17
 
        autoheader
18
 
        ;;
19
 
    -unpatch)
20
 
        patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
21
 
        #rm ${dir}gcc/configure
22
 
        ;;
23
 
    *)
24
 
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
25
 
        exit 1
26
 
esac
27
 
exit 0
28
 
 
29
 
--- configure.in~
30
 
+++ configure.in
31
 
@@ -1980,7 +1980,6 @@
32
 
 
33
 
 # Templates for things AC_DEFINEd more than once.
34
 
 # For a single AC_DEFINE, no template is needed.
35
 
-AH_TEMPLATE(C_THREADS,[Define if you have the Mach cthreads package])
36
 
 AH_TEMPLATE(_REENTRANT,
37
 
   [Define to force use of thread-safe errno, h_errno, and other functions])
38
 
 AH_TEMPLATE(WITH_THREAD,
39
 
@@ -2062,17 +2061,6 @@
40
 
     AC_MSG_RESULT($unistd_defines_pthreads)
41
 
 
42
 
     AC_DEFINE(_REENTRANT)
43
 
-    AC_CHECK_HEADER(cthreads.h, [AC_DEFINE(WITH_THREAD)
44
 
-    AC_DEFINE(C_THREADS)
45
 
-    AC_DEFINE(HURD_C_THREADS, 1,
46
 
-    [Define if you are using Mach cthreads directly under /include])
47
 
-    LIBS="$LIBS -lthreads"
48
 
-    THREADOBJ="Python/thread.o"],[
49
 
-    AC_CHECK_HEADER(mach/cthreads.h, [AC_DEFINE(WITH_THREAD)
50
 
-    AC_DEFINE(C_THREADS)
51
 
-    AC_DEFINE(MACH_C_THREADS, 1,
52
 
-    [Define if you are using Mach cthreads under mach /])
53
 
-    THREADOBJ="Python/thread.o"],[
54
 
     AC_MSG_CHECKING(for --with-pth)
55
 
     AC_ARG_WITH([pth],
56
 
                 AC_HELP_STRING(--with-pth, use GNU pth threading libraries),
57
 
@@ -2123,7 +2111,7 @@
58
 
     LIBS="$LIBS -lcma"
59
 
     THREADOBJ="Python/thread.o"],[
60
 
     USE_THREAD_MODULE="#"])
61
 
-    ])])])])])])])])])
62
 
+    ])])])])])])])
63
 
 
64
 
     AC_CHECK_LIB(mpc, usconfig, [AC_DEFINE(WITH_THREAD)
65
 
     LIBS="$LIBS -lmpc"