~ubuntu-branches/ubuntu/natty/python3.1/natty-security

« back to all changes in this revision

Viewing changes to debian/patches/overwrite-semaphore-check.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2010-07-06 16:52:42 UTC
  • mfrom: (1.2.1 upstream) (2.1.11 sid)
  • Revision ID: james.westby@ubuntu.com-20100706165242-2xv4i019r3et6c0j
Tags: 3.1.2+20100706-1ubuntu1
* Merge with Debian; remaining changes:
  - Regenerate the control file.
  - Add debian/patches/overwrite-semaphore-check for Lucid buildds.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
 
3
 
# DP: Overwrite the semaphore check for lucid; buildds running 2.6.24 kernel
4
 
 
5
 
dir=
6
 
if [ $# -eq 3 -a "$2" = '-d' ]; then
7
 
    pdir="-d $3"
8
 
    dir="$3/"
9
 
elif [ $# -ne 1 ]; then
10
 
    echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
11
 
    exit 1
12
 
fi
13
 
case "$1" in
14
 
    -patch)
15
 
        patch $pdir -f --no-backup-if-mismatch -p1 < $0
16
 
        ;;
17
 
    -unpatch)
18
 
        patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
19
 
        ;;
20
 
    *)
21
 
        echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
22
 
        exit 1
23
 
esac
24
 
exit 0
25
 
 
26
 
--- ./configure.in.orig 2010-04-14 23:59:03.928331544 +0200
27
 
+++ ./configure.in      2010-04-15 00:28:21.823330844 +0200
28
 
@@ -3424,6 +3424,9 @@
29
 
    ac_cv_posix_semaphores_enabled=no,
30
 
    ac_cv_posix_semaphores_enabled=yes)
31
 
 )
32
 
+if test x`lsb_release -sc` = xlucid; then
33
 
+  ac_cv_posix_semaphores_enabled=yes
34
 
+fi
35
 
 AC_MSG_RESULT($ac_cv_posix_semaphores_enabled)
36
 
 if test $ac_cv_posix_semaphores_enabled = no
37
 
 then
38
 
@@ -3456,8 +3459,12 @@
39
 
 }
40
 
 ]
41
 
 ,AC_MSG_RESULT(no),
42
 
+ if test x`lsb_release -sc` = xlucid; then
43
 
+ AC_MSG_RESULT(no)
44
 
+ else
45
 
  AC_MSG_RESULT(yes)
46
 
   AC_DEFINE(HAVE_BROKEN_SEM_GETVALUE, 1, define to 1 if your sem_getvalue is broken.)
47
 
+ fi
48
 
 )
49
 
 
50
 
 # determine what size digit to use for Python's longs