~ubuntu-branches/ubuntu/oneiric/dkms/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/debian-lsb.patch

  • Committer: Bazaar Package Importer
  • Author(s): Benjamin Drung
  • Date: 2010-10-25 01:32:41 UTC
  • mfrom: (2.1.13 sid)
  • Revision ID: james.westby@ubuntu.com-20101025013241-cw5ulnje1j2j4rco
Tags: 2.1.1.2-5ubuntu1
* Merge from Debian unstable, remaining changes:
  - debian/control:
    - depend on patch instead of recommending it, if its missing
      the "patches" feature of dkms will no longer work and that
      will cause build failures (LP: #653899)
  - debian/patches/improve-the-logic-behind-kernels-detection.patch:
    - Before using the current kernel we need to make sure that this
      kernel doesn't belong to the host of a chroot and we should
      also be more careful when adding kernels to the candidates
      list (LP: #602408).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Do not use lsb_release to determine the distribution, add a a static assignment
 
2
 
 
3
This patch should not be merged upstream
 
4
--- a/dkms
 
5
+++ b/dkms
 
6
@@ -363,10 +363,10 @@ function distro_version()
 
7
     if [ -r /etc/lsb-release ]; then
 
8
         . /etc/lsb-release
 
9
         LSB_RELEASE=1
 
10
-    elif type lsb_release >/dev/null 2>&1; then
 
11
-        DISTRIB_ID=$(lsb_release -i -s)
 
12
-        DISTRIB_RELEASE=$(lsb_release -r -s)
 
13
-        LSB_RELEASE=1
 
14
+    else
 
15
+       DISTRIB_ID=Debian
 
16
+       DISTRIB_RELEASE=$(cat /etc/debian_version)
 
17
+       LSB_RELEASE=1
 
18
     fi
 
19
 
 
20
     case "${DISTRIB_ID}" in