~ubuntu-branches/ubuntu/oneiric/dkms/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/mkdsc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Benjamin Drung
  • Date: 2010-10-25 01:32:41 UTC
  • mfrom: (2.1.13 sid)
  • Revision ID: james.westby@ubuntu.com-20101025013241-cw5ulnje1j2j4rco
Tags: 2.1.1.2-5ubuntu1
* Merge from Debian unstable, remaining changes:
  - debian/control:
    - depend on patch instead of recommending it, if its missing
      the "patches" feature of dkms will no longer work and that
      will cause build failures (LP: #653899)
  - debian/patches/improve-the-logic-behind-kernels-detection.patch:
    - Before using the current kernel we need to make sure that this
      kernel doesn't belong to the host of a chroot and we should
      also be more careful when adding kernels to the candidates
      list (LP: #602408).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 55321c5537c963206d51c9965aa7816c7a5dfef0 Mon Sep 17 00:00:00 2001
 
2
From: David Henningsson <david.henningsson@canonical.com>
 
3
Date: Fri, 30 Jul 2010 12:43:48 +0200
 
4
Subject: [PATCH] Copy from the right directory with mkdsc
 
5
 
 
6
Signed-off-by: David Henningsson <david.henningsson@canonical.com>
 
7
---
 
8
 dkms |    2 +-
 
9
 1 files changed, 1 insertions(+), 1 deletions(-)
 
10
 
 
11
From 469f8cc9d9db1390c5ce43fb839240c1538491bc Mon Sep 17 00:00:00 2001
 
12
From: David Henningsson <david.henningsson@canonical.com>
 
13
Date: Fri, 30 Jul 2010 13:15:28 +0200
 
14
Subject: [PATCH 2/2] Also copy source.changes when building with mkdsc
 
15
 
 
16
Signed-off-by: David Henningsson <david.henningsson@canonical.com>
 
17
---
 
18
 dkms |    3 ++-
 
19
 1 files changed, 2 insertions(+), 1 deletions(-)
 
20
--- a/dkms
 
21
+++ b/dkms
 
22
@@ -3390,7 +3390,8 @@ function make_debian()
 
23
                 echo $"Error! There was a problem creating your ${create_type}." >&2
 
24
                 exit 7
 
25
             fi
 
26
-            invoke_command "mv '$temp_dir/${debian_package}-dkms_${module_version}.dsc' '$temp_dir/${debian_package}-dkms_${module_version}.tar.gz' '$deb_basedir'" "Moving built files to $deb_basedir"
 
27
+           package_prefix="$temp_dir/${debian_package}-dkms_${module_version}"
 
28
+           invoke_command "mv '${package_prefix}.dsc' '${package_prefix}_source.changes' '${package_prefix}.tar.gz' '$deb_basedir'" "Moving built files to $deb_basedir"
 
29
             ;;
 
30
         deb)
 
31
             invoke_command "dpkg-buildpackage -rfakeroot -d -b -us -uc 1>/dev/null" "Building binary package"
 
32
@@ -3410,7 +3411,7 @@ function make_debian()
 
33
 
 
34
     if in_temporary_trees; then
 
35
         echo "Copying built files to "`pwd`"/.." >&2
 
36
-        cp "$dkms_tree/$module/$module_version/deb/"* ..
 
37
+        cp "${deb_basedir}/"* ..
 
38
     fi
 
39
 
 
40
     #cleanup