~ubuntu-branches/ubuntu/oneiric/gnome-games/oneiric-updates

« back to all changes in this revision

Viewing changes to debian/patches/00git_private_typelib.patch

  • Committer: Package Import Robot
  • Author(s): Rodrigo Moya
  • Date: 2011-05-30 13:32:04 UTC
  • mfrom: (1.1.92) (3.1.7 experimental)
  • Revision ID: package-import@ubuntu.com-20110530133204-124q7mmr507o3ouj
Tags: 1:3.0.2-0ubuntu1
* Rebased from Debian and GNOME3 PPA. Remaining Ubuntu changes
* debian/control:
  - Keep separation of games in subpackages (gnome-sudoku disabled for now)
  - Build depend on liblaunchpad-integration-3.0-dev, dh-autoreconf and gnome-common
* debian/rules:
  - Use autoreconf.mk for dh-autoreconf
  - Use multiarch location for libraries and introspection
* debian/watch:
  - Watch unstable series
* debian/patches/01_lpi.patch:
  - Launchpad integration
* debian/patches/02_desktop-path.patch:
  - Use full patch for games in /usr/games
* debian/patches/80_change_tetris_theme.patch:
  - Use plain tetris theme by default as tangoshaded runs slow
* debian/patches/81_change_iagno_theme.patch:
  - Use small theme by default

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 9f54cae637585a50700721943c3a19f7c79bc381 Mon Sep 17 00:00:00 2001
2
 
From: Robert Ancell <robert.ancell@canonical.com>
3
 
Date: Wed, 30 Mar 2011 16:49:18 +1100
4
 
Subject: [PATCH 3/3] libgames-support: Install typelib into a private location, don't bother installing the .gir since the library is private and is not going to be extended by other libraries
5
 
 
6
 
---
7
 
 libgames-support/Makefile.am |   11 +----------
8
 
 lightsoff/src/lightsoff.in   |    1 +
9
 
 swell-foop/swell-foop.in     |    1 +
10
 
 3 files changed, 3 insertions(+), 10 deletions(-)
11
 
 
12
 
Index: gnome-games-2.32.1/libgames-support/Makefile.am
13
 
===================================================================
14
 
--- gnome-games-2.32.1.orig/libgames-support/Makefile.am        2011-03-31 12:29:00.038817054 +1100
15
 
+++ gnome-games-2.32.1/libgames-support/Makefile.am     2011-03-31 12:29:53.349199393 +1100
16
 
@@ -199,9 +199,6 @@
17
 
 
18
 
 BUILT_GIRSOURCES = GnomeGamesSupport-1.0.gir
19
 
 
20
 
-# FIXMEchpe: change GIR version for the gtk+-3.0 based one...
21
 
-# or just remove introspection support for the gtk+-2.0 build
22
 
-
23
 
 GnomeGamesSupport-1.0.gir: $(INTROSPECTION_SCANNER) libgames-support-gi.la $(libgames_support_gi_la_SOURCES)
24
 
        $(AM_V_GEN) $(INTROSPECTION_SCANNER) -v \
25
 
        --namespace GnomeGamesSupport --nsversion=1.0 \
26
 
@@ -221,13 +218,10 @@
27
 
        -I$(top_builddir) \
28
 
        $(filter %.h,$^)
29
 
 
30
 
-# FIXMEchpe: this looks bogus. If the introspection.m4 macro gets it wrong, fix it!
31
 
-# INTROSPECTION_GIRDIR/INTROSPECTION_TYPELIBDIR aren't the right place to
32
 
-# install anything - we need to install inside our prefix.
33
 
-girdir = $(datadir)/gir-1.0
34
 
+girdir = $(pkglibdir)
35
 
 gir_DATA = $(BUILT_GIRSOURCES)
36
 
 
37
 
-typelibsdir = $(libdir)/girepository-1.0
38
 
+typelibsdir = $(pkglibdir)
39
 
 typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
40
 
 
41
 
 %.typelib: %.gir $(INTROSPECTION_COMPILER)
42
 
Index: gnome-games-2.32.1/lightsoff/src/lightsoff.in
43
 
===================================================================
44
 
--- gnome-games-2.32.1.orig/lightsoff/src/lightsoff.in  2011-03-31 12:29:00.018816928 +1100
45
 
+++ gnome-games-2.32.1/lightsoff/src/lightsoff.in       2011-03-31 12:29:01.308826194 +1100
46
 
@@ -1,4 +1,5 @@
47
 
 #!/usr/bin/env sh
48
 
 
49
 
 export LD_LIBRARY_PATH="%pkglibdir%${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}"
50
 
+export GI_TYPELIB_PATH="%pkglibdir%${GI_TYPELIB_PATH:+:$GI_TYPELIB_PATH}"
51
 
 /usr/bin/env seed %pkgdatadir%/lightsoff/main.js
52
 
Index: gnome-games-2.32.1/swell-foop/swell-foop.in
53
 
===================================================================
54
 
--- gnome-games-2.32.1.orig/swell-foop/swell-foop.in    2011-03-31 12:29:00.028816989 +1100
55
 
+++ gnome-games-2.32.1/swell-foop/swell-foop.in 2011-03-31 12:29:01.308826194 +1100
56
 
@@ -1,4 +1,5 @@
57
 
 #!/usr/bin/env sh
58
 
 
59
 
 export LD_LIBRARY_PATH="%pkglibdir%${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}"
60
 
+export GI_TYPELIB_PATH="%pkglibdir%${GI_TYPELIB_PATH:+:$GI_TYPELIB_PATH}"
61
 
 /usr/bin/env seed %pkgdatadir%/swell-foop/main.js