~ubuntu-branches/ubuntu/oneiric/gtk-qt-engine/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/01_firefox_patch.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Fathi Boudra, Didier Raboud, Fathi Boudra
  • Date: 2009-06-25 09:35:02 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20090625093502-ovidnbr0okqkm6ua
Tags: 1:1.1+svn5-1
* New svn repository (http://code.google.com/p/gtk-qt-engine)
  - Update upstream package to revision 5
    "Updated Norwegian Nynorsk translation by Karl Ove Hufthammer"

[ Didier Raboud ]

* Change source and binary name to gtk-qt-engine.
  - Bump epoch to 1 due to previous gtk-qt-engine being 1:0.8.
    (Closes: 480696)
  - Use the actual repository revision.
* Update debian/control:
  - Add myself to Uploaders field.
  - Add Vcs-{Svn,Browser} fields.
* Refactorize debian/rules:
  - Remove the custom debian/cdbs directory.
  - Add get-orig-source target.
* Add 04_no_kde4_in_configfile.diff patch (Closes: 527340).

[ Fathi Boudra ]

* Bump Standard-Version to 3.8.2 (no changes needed).
* Update debian/control: drop cdbs build dependency.
* Update debian/copyright: update upstream url.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01-firefox_patch.dpatch by Bastian Venthur <venthur@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
 
9
 
--- gtk-qt-engine-0.8.orig/src/qt_qt_wrapper.cpp        2008-06-07 00:05:35.000000000 +0300
10
 
+++ gtk-qt-engine-0.8/src/qt_qt_wrapper.cpp     2008-06-07 00:07:10.000000000 +0300
11
 
@@ -1720,7 +1720,6 @@
12
 
        gdk_draw_drawable(window, style->bg_gc[state], pix, 0, 0, x, y, w, h);
13
 
        g_object_unref(pix);
14
 
 }
15
 
-
16
 
 void drawFocusRect(GdkWindow * window, GtkStyle * style, int x, int y, int w, int h)
17
 
 {
18
 
        if (!gtkQtEnable)
19
 
@@ -1733,10 +1732,10 @@
20
 
        QPainter painter(&pixmap);
21
 
        QColor bg(qApp->palette().active().background());
22
 
 
23
 
-       painter.fillRect(0,0,w,h,bg);
24
 
+       GdkPixmap* pix = gdk_pixmap_foreign_new(pixmap.handle());
25
 
+       gdk_draw_drawable(pix, style->bg_gc[GTK_STATE_NORMAL], window, x, y, 0, 0, w, h);
26
 
        qApp->style().drawPrimitive(QStyle::PE_FocusRect, &painter, QRect(0,0,w,h), qApp->palette().active(), QStyle::Style_Default, QStyleOption(bg));
27
 
 
28
 
-       GdkPixmap* pix = gdk_pixmap_foreign_new(pixmap.handle());
29
 
        gdk_draw_drawable(window, style->bg_gc[GTK_STATE_NORMAL], pix, 0, 0, x, y, w, h);
30
 
        g_object_unref(pix);
31
 
 }