~ubuntu-branches/ubuntu/oneiric/inspircd/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/02_makeclean.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Giacomo Catenazzi, Darren Blaber, Matt Arnold, Giacomo Catenazzi
  • Date: 2008-03-06 07:56:47 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20080306075647-z8a4phxkn3vo3ajx
Tags: 1.1.17+dfsg-1
[ Darren Blaber ]
* New upstream release, fix /etc/init.d/inspircd stop.
* Fix the postrm script so there is no duplicate update-rc.d
* Fix the manpage so there are no more errors in it

[ Matt Arnold ]
*  Fix prerm so it works (Closes: #466924)

[ Giacomo Catenazzi ]
* Added me as uploader
* Add again support of dpatch in debian/rules
* Build sources only once!
* Correct make clean target, not to include generated ./inspircd on sources
* Don't change permission of configuration files, when starting inspircd
  (separation of policy and program).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## makeclean.dpatch by  <cate@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: add -f flag, allowing to do twice make clean
 
6
## DP: remove also ./inspircd file
 
7
 
 
8
@DPATCH@
 
9
diff -urNad trunk~/.Makefile.inc trunk/.Makefile.inc
 
10
--- trunk~/.Makefile.inc        2007-07-16 20:18:03.000000000 +0200
 
11
+++ trunk/.Makefile.inc 2008-03-05 08:54:54.000000000 +0100
 
12
@@ -201,11 +201,12 @@
 
13
 
 
14
 configureclean:
 
15
        rm -f .config.cache
 
16
-       rm src/modules/Makefile
 
17
-       rm src/Makefile
 
18
-       rm Makefile
 
19
-       rm include/inspircd_config.h
 
20
-       rm include/inspircd_se_config.h
 
21
+       rm -f src/modules/Makefile
 
22
+       rm -f src/Makefile
 
23
+       rm -f Makefile
 
24
+       rm -f include/inspircd_config.h
 
25
+       rm -f include/inspircd_se_config.h
 
26
+       rm -f inspircd
 
27
 
 
28
 distclean: modclean clean configureclean
 
29