~ubuntu-branches/ubuntu/oneiric/inspircd/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/03_disable_chmod.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Giacomo Catenazzi, Darren Blaber, Matt Arnold, Giacomo Catenazzi
  • Date: 2008-03-06 07:56:47 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20080306075647-z8a4phxkn3vo3ajx
Tags: 1.1.17+dfsg-1
[ Darren Blaber ]
* New upstream release, fix /etc/init.d/inspircd stop.
* Fix the postrm script so there is no duplicate update-rc.d
* Fix the manpage so there are no more errors in it

[ Matt Arnold ]
*  Fix prerm so it works (Closes: #466924)

[ Giacomo Catenazzi ]
* Added me as uploader
* Add again support of dpatch in debian/rules
* Build sources only once!
* Correct make clean target, not to include generated ./inspircd on sources
* Don't change permission of configuration files, when starting inspircd
  (separation of policy and program).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 03_disable_chmod.dpatch by  <cate@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Don't change permission of configuration file!
 
6
## DP: we don't want to override sysadmin policies!
 
7
 
 
8
@DPATCH@
 
9
diff -urNad trunk~/src/configreader.cpp trunk/src/configreader.cpp
 
10
--- trunk~/src/configreader.cpp 2008-01-10 14:45:53.000000000 +0100
 
11
+++ trunk/src/configreader.cpp  2008-03-05 08:57:49.000000000 +0100
 
12
@@ -967,7 +967,7 @@
 
13
        }
 
14
 
 
15
        /* Fix the chmod of the file to restrict it to the current user and group */
 
16
-       chmod(filename,0600);
 
17
+       //chmod(filename,0600);
 
18
 
 
19
        for (unsigned int t = 0; t < include_stack.size(); t++)
 
20
        {