~ubuntu-branches/ubuntu/oneiric/squid3/oneiric-security

« back to all changes in this revision

Viewing changes to debian/patches/04-m68k-ftbfs.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Luigi Gangitano
  • Date: 2007-05-13 16:03:16 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20070513160316-2h6kn6h1z0q1fvyo
Tags: 3.0.PRE6-1
* New upstream release
  - Removed patches integrated upsteam:
    + 04-m68k-ftbfs

* debian/rules
  - Enable delay pools (Closes: #410785)
  - Enable cache digests (Closes: #416631)
  - Enable ICAP client
  - Raised Max Filedescriptor limit to 65536

* debian/control
  - Added real package dependency for httpd in squid3-cgi

* debian/patches/02-makefile-defaults
  - Fix default configuration file for cachemgr.cgi (Closes: #416630)

* debian/squid3.postinst
  - Fixed bashish in postinst (Closes: #411797)

* debian/patches/05-helpers-typo
  - Added upstream patch fixing compilation error in src/helpers.cc

* debian/patches/06-mem-obj-reference
  - Added upstream patch fixing a mem_obj reference in src/store.cc

* debian/patches/07-close-icap-connections
  - Added upstream patch fixing icap connection starvation

* debian/squid3.rc
  - Added LSB-compliant description to rc script

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 04-m68k-ftbfs.dpatch by Luigi Gangitano <luigi@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad squid3-3.0.PRE5~/helpers/ntlm_auth/SMB/ntlm_auth.c squid3-3.0.PRE5/helpers/ntlm_auth/SMB/ntlm_auth.c
9
 
--- squid3-3.0.PRE5~/helpers/ntlm_auth/SMB/ntlm_auth.c  2006-04-23 20:21:56.000000000 +0200
10
 
+++ squid3-3.0.PRE5/helpers/ntlm_auth/SMB/ntlm_auth.c   2006-11-09 15:48:16.000000000 +0100
11
 
@@ -308,7 +308,7 @@
12
 
            SEND("NA Broken authentication packet");
13
 
            return;
14
 
        }
15
 
-       switch le32toh(fast_header->type) {
16
 
+       switch (le32toh(fast_header->type)) {
17
 
        case NTLM_NEGOTIATE:
18
 
            SEND("NA Invalid negotiation request received");
19
 
            return;