~ubuntu-branches/ubuntu/oneiric/suitesparse/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/13-UFconfig_UFconfig.mk.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Nick Ellery
  • Date: 2009-06-14 19:15:52 UTC
  • mfrom: (7.2.2 sid)
  • Revision ID: james.westby@ubuntu.com-20090614191552-2hliya5q8n1quseu
Tags: 1:3.4.0-1ubuntu1
* Merge from debian unstable, remaining changes (LP: #387137):
  - debian/control:
    - demote libatlas-doc from recommends to suggests as it is not in main
    - drop recommends on doc-central as it is not in main

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## UFconfig.mk.dpatch by Christophe Prud'homme <prudhomm@debian.org> <prudhomm@mit.edu>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: * Do not use metis library
6
 
## DP: * Drop the fortran libraries from linking options
7
 
## DP: * Link against lapackgf-3 library
8
 
 
9
 
@DPATCH@
10
 
diff -urNad suitesparse-3.2.0~/UFconfig/UFconfig.mk suitesparse-3.2.0/UFconfig/UFconfig.mk
11
 
--- suitesparse-3.2.0~/UFconfig/UFconfig.mk     2008-12-07 17:52:54.000000000 +0100
12
 
+++ suitesparse-3.2.0/UFconfig/UFconfig.mk      2008-12-07 17:53:36.000000000 +0100
13
 
@@ -89,8 +89,8 @@
14
 
 # BLAS = -lgoto -lgfortran -lgfortranbegin -lg2c
15
 
 
16
 
 # This is probably slow ... it might connect to the Standard Reference BLAS:
17
 
-BLAS = -lblas -lgfortran -lgfortranbegin -lg2c
18
 
-LAPACK = -llapack
19
 
+BLAS = -lblas
20
 
+LAPACK = -llapackgf-3
21
 
 
22
 
 # Using non-optimized versions:
23
 
 # BLAS = -lblas_plain -lgfortran -lgfortranbegin -lg2c
24
 
@@ -122,13 +122,13 @@
25
 
 # The path is relative to where it is used, in CHOLMOD/Lib, CHOLMOD/MATLAB, etc.
26
 
 # You may wish to use an absolute path.  METIS is optional.  Compile
27
 
 # CHOLMOD with -DNPARTITION if you do not wish to use METIS.
28
 
-METIS_PATH = ../../metis-4.0
29
 
-METIS = ../../metis-4.0/libmetis.a
30
 
+#METIS_PATH = ../../metis-4.0
31
 
+#METIS = ../../metis-4.0/libmetis.a
32
 
 
33
 
 # If you use CHOLMOD_CONFIG = -DNPARTITION then you must use the following
34
 
 # options:
35
 
-# METIS_PATH =
36
 
-# METIS =
37
 
+METIS_PATH =
38
 
+METIS =
39
 
 
40
 
 #------------------------------------------------------------------------------
41
 
 # UMFPACK configuration:
42
 
@@ -184,7 +184,7 @@
43
 
 # -DNSUNPERF       for Solaris only.  If defined, do not use the Sun
44
 
 #                      Performance Library
45
 
 
46
 
-CHOLMOD_CONFIG =
47
 
+CHOLMOD_CONFIG = -DNPARTITION
48
 
 
49
 
 #------------------------------------------------------------------------------
50
 
 # SuiteSparseQR configuration:
51
 
@@ -198,7 +198,7 @@
52
 
 # -DHAVE_TBB        enable the use of Intel's Threading Building Blocks (TBB)
53
 
 
54
 
 # default, without timing, without TBB:
55
 
-SPQR_CONFIG =
56
 
+SPQR_CONFIG = -DNPARTITION
57
 
 # with timing and TBB:
58
 
 # SPQR_CONFIG = -DTIMING -DHAVE_TBB
59
 
 # with timing