~ubuntu-branches/ubuntu/precise/gnome-games/precise

« back to all changes in this revision

Viewing changes to debian/patches/git_fix-iagno-ai.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2012-03-19 20:46:10 UTC
  • mfrom: (1.1.105)
  • Revision ID: package-import@ubuntu.com-20120319204610-2nd2xqq39j8y7t5q
Tags: 1:3.3.92-0ubuntu1
* New upstream release.
  - Swell Foop ported to Vala, no longer in staging
    (LP: #939200, LP: #939210)
* debian/patches/git_fix-iagno-ai.patch: Dropped, upstream
* debian/control.in:
  - Drop no longer needed swell-foop dependencies
* debian/rules:
  - Don't install staging games
* debian/swell-foop.install:
  - Don't install gir files any more; they're not needed

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From b2554eaa4b96e56e43bc29859b1fcd13984ad2f9 Mon Sep 17 00:00:00 2001
2
 
From: Thomas Hindoe Paaboel Andersen <phomes@gmail.com>
3
 
Date: Wed, 07 Mar 2012 19:00:25 +0000
4
 
Subject: iagno: Game.copy should use width/height from the original
5
 
 
6
 
Before it would use the properties on the new instance that would both be 0.
7
 
 
8
 
The bug will only occur when the AI must make a move on a board with >8 pieces.
9
 
 
10
 
GNOME bug #668553
11
 
---
12
 
diff --git a/iagno/src/game.vala b/iagno/src/game.vala
13
 
index c1f2f7f..d6430ac 100644
14
 
--- a/iagno/src/game.vala
15
 
+++ b/iagno/src/game.vala
16
 
@@ -111,7 +111,7 @@ public class Game
17
 
 
18
 
     public Game.copy (Game game)
19
 
     {
20
 
-        tiles = new Player[width, height];
21
 
+        tiles = new Player[game.width, game.height];
22
 
         for (var x = 0; x < width; x++)
23
 
             for (var y = 0; y < height; y++)
24
 
                 tiles[x, y] = game.tiles[x, y];