~ubuntu-branches/ubuntu/precise/mesa-lts-raring/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_gbm_no_undefined.diff

  • Committer: Package Import Robot
  • Author(s): Maarten Lankhorst
  • Date: 2013-10-16 13:52:07 UTC
  • mfrom: (1.1.2)
  • Revision ID: package-import@ubuntu.com-20131016135207-9gtod705bh0zpbxe
Tags: 9.1.7-1ubuntu2~precise1
Copy from raring, new upstream release. (LP: #1236340)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
 
2
index e22c55c..556eb03 100644
 
3
--- a/src/gbm/Makefile.am
 
4
+++ b/src/gbm/Makefile.am
 
5
@@ -18,7 +18,7 @@ libgbm_la_SOURCES = \
 
6
        main/gbm.c \
 
7
        main/backend.c \
 
8
        main/common.c
 
9
-libgbm_la_LDFLAGS = -version-info 1:0
 
10
+libgbm_la_LDFLAGS = -version-info 1:0 -Wl,-z,defs
 
11
 libgbm_la_LIBADD = $(LIBUDEV_LIBS) $(LIBKMS_LIBS) $(DLOPEN_LIBS)
 
12
 
 
13
 if HAVE_EGL_PLATFORM_WAYLAND
 
14
@@ -39,6 +39,8 @@ libgbm_dri_la_CFLAGS = \
 
15
 
 
16
 libgbm_la_LIBADD += \
 
17
        libgbm_dri.la $(top_builddir)/src/mapi/shared-glapi/libglapi.la
 
18
+
 
19
+libgbm_la_LDFLAGS += $(LIBDRM_LIBS)
 
20
 endif
 
21
 
 
22
 all-local: libgbm.la