~ubuntu-branches/ubuntu/precise/puredata/precise

« back to all changes in this revision

Viewing changes to debian/patches/01_big_endian.diff

  • Committer: Bazaar Package Importer
  • Author(s): Paul Brossier
  • Date: 2009-12-22 21:29:31 UTC
  • mfrom: (1.2.6 upstream) (4.1.2 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091222212931-nhwkzapjwsmjao1l
Tags: 0.42.5-3
* debian/control:
  - add community site to homepage field
  - improve long description
  - remove Replaces and Conflicts fields
  - add Suggests on pd-csound, pd-pdp, pd-zexy, pd-aubio
* debian/rules: add per-arch configuration flags
* debian/patches/02_kfreebsd.diff:
  - also define pd_tilde_dllextent on FreeBSD
  - fix typo (really closing #414414 this time)
  - also add hurd glue
* debian/patches/04_hurd.diff:
  - add hurd glue and s_midi_dummy.c

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff --git a/src/s_audio_alsa.c b/src/s_audio_alsa.c
 
2
index a5034c8..bc694b0 100644
 
3
--- a/src/s_audio_alsa.c
 
4
+++ b/src/s_audio_alsa.c
 
5
@@ -469,7 +469,7 @@ int alsa_send_dacs(void)
 
6
                 ((char *)(alsa_snd_buf))[3*j+1] = ((s>>8) & 255);
 
7
                 ((char *)(alsa_snd_buf))[3*j+2] = ((s>>16) & 255);
 
8
 #else
 
9
-                fprintf(stderr("big endian 24-bit not supported");
 
10
+                fprintf(stderr,"big endian 24-bit not supported");
 
11
 #endif
 
12
             }
 
13
             for (; i < thisdevchans; i++, ch++)
 
14
@@ -581,7 +581,7 @@ int alsa_send_dacs(void)
 
15
                         * (1./ INT32_MAX);
 
16
             }
 
17
 #else
 
18
-                fprintf(stderr("big endian 24-bit not supported");
 
19
+                fprintf(stderr,"big endian 24-bit not supported");
 
20
 #endif
 
21
         }
 
22
         else