~ubuntu-branches/ubuntu/precise/tcpdump/precise-updates

« back to all changes in this revision

Viewing changes to debian/patches/20_man_fixes.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Romain Francoise
  • Date: 2008-03-08 19:24:02 UTC
  • mfrom: (6.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080308192402-9n7erk2yyyd5mpt3
Tags: 3.9.8-4
debian/control: Build-Depend on libpcap0.8-dev (>= 0.9.3),
not (>= 0.9.3-1).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 20_man_fixes.dpatch by Romain Francoise <rfrancoise@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Misc. fixes to the upstream man page.
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
    -patch) patch -p1 ${patch_opts} < $0;;
17
 
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
18
 
    *)
19
 
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
diff -urNad tcpdump-3.9.4~/tcpdump.1 tcpdump-3.9.4/tcpdump.1
27
 
--- tcpdump-3.9.4~/tcpdump.1    2006-02-02 22:21:06.000000000 +0100
28
 
+++ tcpdump-3.9.4/tcpdump.1     2006-02-02 22:22:26.000000000 +0100
29
 
@@ -22,7 +22,7 @@
30
 
 .\" WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF
31
 
 .\" MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
32
 
 .\"
33
 
-.TH TCPDUMP 1  "18 April 2005"
34
 
+.TH TCPDUMP 8  "18 April 2005"
35
 
 .SH NAME
36
 
 tcpdump \- dump traffic on a network
37
 
 .SH SYNOPSIS
38
 
@@ -306,7 +306,7 @@
39
 
 .B \-E
40
 
 Use \fIspi@ipaddr algo:secret\fP for decrypting IPsec ESP packets that
41
 
 are addressed to \fIaddr\fP and contain Security Parameter Index value
42
 
-\fIspi\fP. This combination may be repeated with comma or newline seperation.
43
 
+\fIspi\fP. This combination may be repeated with comma or newline separation.
44
 
 .IP
45
 
 Note that setting the secret for IPv4 ESP packets is supported at this time.
46
 
 .IP
47
 
@@ -322,7 +322,7 @@
48
 
 with cryptography enabled.
49
 
 .IP
50
 
 \fIsecret\fP is the ASCII text for ESP secret key. 
51
 
-If preceeded by 0x, then a hex value will be read.
52
 
+If preceded by 0x, then a hex value will be read.
53
 
 .IP
54
 
 The option assumes RFC2406 ESP, not RFC1827 ESP.
55
 
 The option is only for debugging purposes, and
56
 
@@ -715,7 +715,7 @@
57
 
 True if the Ethernet destination address is \fIehost\fP.
58
 
 \fIEhost\fP
59
 
 may be either a name from /etc/ethers or a number (see
60
 
-.IR ethers (3N)
61
 
+.IR ethers (5)
62
 
 for numeric format).
63
 
 .IP "\fBether src \fIehost\fP
64
 
 True if the Ethernet source address is \fIehost\fP.
65
 
@@ -761,9 +761,9 @@
66
 
 True if the packet is ip/tcp, ip/udp, ip6/tcp or ip6/udp and has a
67
 
 destination port value of \fIport\fP.
68
 
 The \fIport\fP can be a number or a name used in /etc/services (see
69
 
-.IR tcp (4P)
70
 
+.IR tcp (7)
71
 
 and
72
 
-.IR udp (4P)).
73
 
+.IR udp (7)).
74
 
 If a name is used, both the port
75
 
 number and protocol are checked.
76
 
 If a number or ambiguous name is used,
77
 
@@ -954,7 +954,7 @@
78
 
 (applies only to packets logged by OpenBSD's
79
 
 .BR pf (4)).
80
 
 .IP "\fBrulenum \fInum\fR"
81
 
-Synonomous with the
82
 
+Synonymous with the
83
 
 .B rnr
84
 
 modifier.
85
 
 .IP "\fBreason \fIcode\fR"
86
 
@@ -974,7 +974,7 @@
87
 
 name of an anchored ruleset (applies only to packets logged by
88
 
 .BR pf (4)).
89
 
 .IP "\fBruleset \fIname\fR"
90
 
-Synonomous with the
91
 
+Synonymous with the
92
 
 .B rset
93
 
 modifier.
94
 
 .IP "\fBsrnr \fInum\fR"
95
 
@@ -982,7 +982,7 @@
96
 
 of an anchored ruleset (applies only to packets logged by
97
 
 .BR pf (4)).
98
 
 .IP "\fBsubrulenum \fInum\fR"
99
 
-Synonomous with the
100
 
+Synonymous with the
101
 
 .B srnr
102
 
 modifier.
103
 
 .IP "\fBaction \fIact\fR"