~ubuntu-branches/ubuntu/precise/tcpdump/precise-updates

« back to all changes in this revision

Viewing changes to debian/patches/30_vlan_eflag.diff

  • Committer: Bazaar Package Importer
  • Author(s): Romain Francoise
  • Date: 2008-03-08 19:24:02 UTC
  • mfrom: (6.1.3 hardy)
  • Revision ID: james.westby@ubuntu.com-20080308192402-9n7erk2yyyd5mpt3
Tags: 3.9.8-4
debian/control: Build-Depend on libpcap0.8-dev (>= 0.9.3),
not (>= 0.9.3-1).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Reverse test for eflag in print-ether.c to match the intended effect
 
2
(hide vlan info if called with -e).
 
3
 
 
4
--- tcpdump-3.9.5.orig/print-ether.c
 
5
+++ tcpdump-3.9.5/print-ether.c
 
6
@@ -220,7 +220,7 @@
 
7
                return (1);
 
8
 
 
9
        case ETHERTYPE_8021Q:
 
10
-               if (eflag)
 
11
+               if (!eflag)
 
12
                    printf("vlan %u, p %u%s, ",
 
13
                           ntohs(*(u_int16_t *)p) & 0xfff,
 
14
                           ntohs(*(u_int16_t *)p) >> 13,