~ubuntu-branches/ubuntu/quantal/brasero/quantal-updates

« back to all changes in this revision

Viewing changes to debian/patches/014_fix_format_security_errors.patch

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2012-02-22 23:31:45 UTC
  • mfrom: (1.2.16 sid)
  • Revision ID: package-import@ubuntu.com-20120222233145-2xbst2a32ae543vh
Tags: 3.2.0-3ubuntu1
* Sync with Debian. Remaining changes:
* debian/control:
  - Build-Depend on libappindicator3-dev, libunity-dev, and 
    liblaunchpad-integration-3.0-dev
  - Don't build-depend on tracker
  - Recommends: brasero-cdrkit
  - libbrasero-media3-1 Depend on dvd+rw-tools not growisofs and
    Suggest rather than Recommend gstreamer plugins & cdrdao
  - Also suggest gstreamer fluendo mp3 plugin
  - Have brasero-cdrkit Suggest, not Recommend, dvdauthor as it isn't
    in main.
* debian/patches/010_lpi.patch:
  - Launchpad integration patch
* debian/patches/012_appindicator.patch:
  - Use application indicators
* debian/patches/013_unity_launcher_progress: Display burn progress
  in Brasero's Unity launcher icon.
* debian/patches/014_fix_format_security_errors.patch: Fix FTBFS caused by
  -Werror=format-security errors, pulled from upstream git
* debian/patches/git_drive_selection.patch: correctly display the default
  drive as selected, thanks "Fido" and Robert Roth (lp: #848340)
* debian/rules:
  - Don't build search (requires tracker) but build unity support

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 9c696d0e72bf2a105750fba9efb01518a958efce Mon Sep 17 00:00:00 2001
2
 
From: Jean Schurger <jean@schurger.org>
3
 
Date: Thu, 20 Oct 2011 20:42:20 +0200
4
 
Subject: [PATCH] Fix printf format string handling, bug 661091
5
 
 
6
 
Without this patch, Brasero fails to build if GCC has
7
 
-Werror=format-security enabled.
8
 
---
9
 
 plugins/libburnia/burn-libisofs.c  |    4 ++--
10
 
 plugins/transcode/burn-transcode.c |    2 +-
11
 
 2 files changed, 3 insertions(+), 3 deletions(-)
12
 
 
13
 
Index: brasero-3.2.0/plugins/libburnia/burn-libisofs.c
14
 
===================================================================
15
 
--- brasero-3.2.0.orig/plugins/libburnia/burn-libisofs.c        2011-09-27 19:19:01.000000000 +1000
16
 
+++ brasero-3.2.0/plugins/libburnia/burn-libisofs.c     2011-11-18 09:22:04.353736546 +1100
17
 
@@ -219,7 +219,7 @@
18
 
        if (read_bytes == -1 && !priv->error)
19
 
                priv->error = g_error_new (BRASERO_BURN_ERROR,
20
 
                                           BRASERO_BURN_ERROR_GENERAL,
21
 
-                                          _("Volume could not be created"));
22
 
+                                          "%s", _("Volume could not be created"));
23
 
 }
24
 
 
25
 
 static void
26
 
@@ -567,7 +567,7 @@
27
 
        brasero_job_get_data_label (BRASERO_JOB (self), &label);
28
 
        if (!iso_image_new (label, &image)) {
29
 
                priv->error = g_error_new (BRASERO_BURN_ERROR,
30
 
-                                          BRASERO_BURN_ERROR_GENERAL,
31
 
+                                          BRASERO_BURN_ERROR_GENERAL, "%s",
32
 
                                           _("Volume could not be created"));
33
 
                g_free (label);
34
 
                goto end;
35
 
Index: brasero-3.2.0/plugins/transcode/burn-transcode.c
36
 
===================================================================
37
 
--- brasero-3.2.0.orig/plugins/transcode/burn-transcode.c       2011-09-27 19:19:01.000000000 +1000
38
 
+++ brasero-3.2.0/plugins/transcode/burn-transcode.c    2011-11-18 09:22:04.357736546 +1100
39
 
@@ -1346,7 +1346,7 @@
40
 
        if (duration == -1 || duration == 0)    
41
 
            brasero_job_error (BRASERO_JOB (transcode),
42
 
                               g_error_new (BRASERO_BURN_ERROR,
43
 
-                                           BRASERO_BURN_ERROR_GENERAL,
44
 
+                                           BRASERO_BURN_ERROR_GENERAL, "%s",
45
 
                                            _("Error while getting duration")));
46
 
        return duration;
47
 
 }
48
 
Index: brasero-3.2.0/plugins/libburnia/burn-libburn.c
49
 
===================================================================
50
 
--- brasero-3.2.0.orig/plugins/libburnia/burn-libburn.c 2011-09-27 19:19:01.000000000 +1000
51
 
+++ brasero-3.2.0/plugins/libburnia/burn-libburn.c      2011-11-18 09:22:04.357736546 +1100
52
 
@@ -563,7 +563,7 @@
53
 
                BRASERO_JOB_LOG (BRASERO_JOB (self), "Precheck failed %s", reason);
54
 
                g_set_error (error,
55
 
                             BRASERO_BURN_ERROR,
56
 
-                            BRASERO_BURN_ERROR_GENERAL,
57
 
+                            BRASERO_BURN_ERROR_GENERAL, "%s",
58
 
                             reason);
59
 
                return BRASERO_BURN_ERR;
60
 
        }
61
 
Index: brasero-3.2.0/plugins/libburnia/burn-libburn-common.c
62
 
===================================================================
63
 
--- brasero-3.2.0.orig/plugins/libburnia/burn-libburn-common.c  2011-09-27 19:19:01.000000000 +1000
64
 
+++ brasero-3.2.0/plugins/libburnia/burn-libburn-common.c       2011-11-18 09:22:49.773735295 +1100
65
 
@@ -221,7 +221,7 @@
66
 
 
67
 
        BRASERO_JOB_LOG (self, "Libburn reported an error %s", err_txt);
68
 
        error = g_error_new (BRASERO_BURN_ERROR,
69
 
-                            BRASERO_BURN_ERROR_GENERAL,
70
 
+                            BRASERO_BURN_ERROR_GENERAL, "%s",
71
 
                             err_txt);
72
 
        brasero_job_error (BRASERO_JOB (self), error);
73
 
        return FALSE;