~ubuntu-branches/ubuntu/quantal/brasero/quantal-updates

« back to all changes in this revision

Viewing changes to debian/patches/02_gcc-format-security

  • Committer: Package Import Robot
  • Author(s): Jeremy Bicha
  • Date: 2012-02-22 23:31:45 UTC
  • mfrom: (1.2.16 sid)
  • Revision ID: package-import@ubuntu.com-20120222233145-2xbst2a32ae543vh
Tags: 3.2.0-3ubuntu1
* Sync with Debian. Remaining changes:
* debian/control:
  - Build-Depend on libappindicator3-dev, libunity-dev, and 
    liblaunchpad-integration-3.0-dev
  - Don't build-depend on tracker
  - Recommends: brasero-cdrkit
  - libbrasero-media3-1 Depend on dvd+rw-tools not growisofs and
    Suggest rather than Recommend gstreamer plugins & cdrdao
  - Also suggest gstreamer fluendo mp3 plugin
  - Have brasero-cdrkit Suggest, not Recommend, dvdauthor as it isn't
    in main.
* debian/patches/010_lpi.patch:
  - Launchpad integration patch
* debian/patches/012_appindicator.patch:
  - Use application indicators
* debian/patches/013_unity_launcher_progress: Display burn progress
  in Brasero's Unity launcher icon.
* debian/patches/014_fix_format_security_errors.patch: Fix FTBFS caused by
  -Werror=format-security errors, pulled from upstream git
* debian/patches/git_drive_selection.patch: correctly display the default
  drive as selected, thanks "Fido" and Robert Roth (lp: #848340)
* debian/rules:
  - Don't build search (requires tracker) but build unity support

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: fix build break with -Werror=format-security
 
2
Bug: b-g-o #661091
 
3
Index: brasero-3.2.0/plugins/libburnia/burn-libisofs.c
 
4
===================================================================
 
5
--- brasero-3.2.0.orig/plugins/libburnia/burn-libisofs.c        2011-09-27 05:19:01.000000000 -0400
 
6
+++ brasero-3.2.0/plugins/libburnia/burn-libisofs.c     2011-10-06 10:29:43.694973360 -0400
 
7
@@ -219,7 +219,7 @@
 
8
        if (read_bytes == -1 && !priv->error)
 
9
                priv->error = g_error_new (BRASERO_BURN_ERROR,
 
10
                                           BRASERO_BURN_ERROR_GENERAL,
 
11
-                                          _("Volume could not be created"));
 
12
+                                          "%s", _("Volume could not be created"));
 
13
 }
 
14
 
 
15
 static void
 
16
@@ -567,7 +567,7 @@
 
17
        brasero_job_get_data_label (BRASERO_JOB (self), &label);
 
18
        if (!iso_image_new (label, &image)) {
 
19
                priv->error = g_error_new (BRASERO_BURN_ERROR,
 
20
-                                          BRASERO_BURN_ERROR_GENERAL,
 
21
+                                          BRASERO_BURN_ERROR_GENERAL, "%s",
 
22
                                           _("Volume could not be created"));
 
23
                g_free (label);
 
24
                goto end;
 
25
Index: brasero-3.2.0/plugins/transcode/burn-transcode.c
 
26
===================================================================
 
27
--- brasero-3.2.0.orig/plugins/transcode/burn-transcode.c       2011-09-27 05:19:01.000000000 -0400
 
28
+++ brasero-3.2.0/plugins/transcode/burn-transcode.c    2011-10-06 10:31:02.189967994 -0400
 
29
@@ -1346,7 +1346,7 @@
 
30
        if (duration == -1 || duration == 0)    
 
31
            brasero_job_error (BRASERO_JOB (transcode),
 
32
                               g_error_new (BRASERO_BURN_ERROR,
 
33
-                                           BRASERO_BURN_ERROR_GENERAL,
 
34
+                                           BRASERO_BURN_ERROR_GENERAL, "%s",
 
35
                                            _("Error while getting duration")));
 
36
        return duration;
 
37
 }