~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/903_skip_base_ruby_check.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2009-07-30 19:06:31 UTC
  • Revision ID: james.westby@ubuntu.com-20090730190631-3x30w2mtev71ah62
Tags: 1.9.1.243-0ubuntu1
* Upload snapshot from Debian's pkg-ruby SVN repository to karmic.
  SVN revision: 235.
  Likely to be similar to the final package uploaded to Debian.
  Known issues:
  + lintian warnings/errors (nothing important)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 903_skip_base_ruby_check.dpatch by akira yamada <akira@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: skip host ruby check.  (this packages uses pre-generated files.)
 
6
 
 
7
@DPATCH@
 
8
diff -urNad ruby1.9-1.9.1.0~/configure.in ruby1.9-1.9.1.0/configure.in
 
9
--- ruby1.9-1.9.1.0~/configure.in       2009-02-03 14:06:43.000000000 +0900
 
10
+++ ruby1.9-1.9.1.0/configure.in        2009-02-03 14:07:25.000000000 +0900
 
11
@@ -18,8 +18,6 @@
 
12
        [
 
13
                BASERUBY="ruby"
 
14
        ])
 
15
-test "`RUBYOPT=- $BASERUBY -e 'p 42' 2>/dev/null`" = 42 ||
 
16
-    BASERUBY="echo executable host ruby is required.  use --with-baseruby option.; false"
 
17
 AC_SUBST(BASERUBY)
 
18
 
 
19
 AC_DEFUN([RUBY_MINGW32],