~ubuntu-branches/ubuntu/quantal/ruby1.9.1/quantal

« back to all changes in this revision

Viewing changes to debian/patches/904_linux_target_os.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2009-07-30 19:06:31 UTC
  • Revision ID: james.westby@ubuntu.com-20090730190631-3x30w2mtev71ah62
Tags: 1.9.1.243-0ubuntu1
* Upload snapshot from Debian's pkg-ruby SVN repository to karmic.
  SVN revision: 235.
  Likely to be similar to the final package uploaded to Debian.
  Known issues:
  + lintian warnings/errors (nothing important)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 904_linux_target_os.dpatch.dpatch by Matthias Klose <doko@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Robustify check for target_os
 
6
 
 
7
@DPATCH@
 
8
--- ./configure.in~     2007-09-04 17:20:41.000000000 +0200
 
9
+++ ./configure.in      2007-09-04 17:34:11.000000000 +0200
 
10
@@ -90,7 +90,7 @@
 
11
 fi
 
12
 
 
13
 AC_CANONICAL_TARGET
 
14
-target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnu/linux-/'`
 
15
+target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnulp$/linux/;s/linux-gnu/linux-/'`
 
16
 ac_install_sh='' # unusable for extension libraries.
 
17
 
 
18
 dnl checks for fat-binary