~ubuntu-branches/ubuntu/quantal/virtinst/quantal-updates

« back to all changes in this revision

Viewing changes to debian/patches/0004-Fix-location-of-Debian-daily-builds.patch

  • Committer: Package Import Robot
  • Author(s): Marc Deslauriers
  • Date: 2012-07-24 08:52:01 UTC
  • mfrom: (1.6.8 sid)
  • Revision ID: package-import@ubuntu.com-20120724085201-q3h0cbabg4t46gfm
Tags: 0.600.2-1ubuntu1
* Merge from debian unstable. Remaining changes:
  - debian/patches/9003-fix-path-to-hvmloader-in-testsuite.patch: adjust
    testsuite for 0001-fix-path-to-hvmloader.patch and
    0002-Fix-path-to-pygrub.patch.
  - debian/patches/9004_ubuntu_fix_tree_support.patch: Fix tree detection
    for all ISO/HTTP source, to not longer fail with cobbler/koan.
  - debian/patches/0004-Fix-path-to-qemu-dm.patch: fix the path to the
    qemu-dm binary.
  - debian/{control,rules,pyversions}: Build using dh_python2, use
    debhelper v8 instead of cdbs; for some reason the package build an
    empty binary package when using dh_python2.
  - debian/control: added acl package to depends.
  - debian/control: added libvirt-bin to recommends
* Dropped patches:
  - debian/patches/9005_ubuntu_releases.patch: Upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Gaudenz Steinlin <gaudenz@debian.org>
2
 
Date: Mon, 16 Apr 2012 13:54:23 +0200
3
 
Subject: Fix location of Debian daily builds
4
 
MIME-Version: 1.0
5
 
Content-Type: text/plain; charset=UTF-8
6
 
Content-Transfer-Encoding: 8bit
7
 
 
8
 
When selecting a distribution tree over http as an installation source
9
 
the URL for Debian daily builds is not recognized because the layout
10
 
changed. Daily builds are no longer hosted on joeyhs p.d.o site but on
11
 
d-i.debian.org.
12
 
 
13
 
Signed-off-by: Guido Günther <agx@sigxcpu.org>
14
 
---
15
 
 virtinst/OSDistro.py |   10 +++++-----
16
 
 1 file changed, 5 insertions(+), 5 deletions(-)
17
 
 
18
 
diff --git a/virtinst/OSDistro.py b/virtinst/OSDistro.py
19
 
index f30e6e4..69be4af 100644
20
 
--- a/virtinst/OSDistro.py
21
 
+++ b/virtinst/OSDistro.py
22
 
@@ -889,16 +889,16 @@ class SuseDistro(Distro):
23
 
 
24
 
 class DebianDistro(Distro):
25
 
     # ex. http://ftp.egr.msu.edu/debian/dists/sarge/main/installer-i386/
26
 
-    # daily builds: http://people.debian.org/~joeyh/d-i/
27
 
+    # daily builds: http://d-i.debian.org/daily-images/amd64/ 
28
 
 
29
 
     name = "Debian"
30
 
     os_type = "linux"
31
 
 
32
 
     def __init__(self, uri, arch, vmtype=None, scratchdir=None):
33
 
         Distro.__init__(self, uri, arch, vmtype, scratchdir)
34
 
-        if uri.count("installer-i386"):
35
 
+        if uri.count("i386"):
36
 
             self._treeArch = "i386"
37
 
-        elif uri.count("installer-amd64"):
38
 
+        elif uri.count("amd64"):
39
 
             self._treeArch = "amd64"
40
 
         else:
41
 
             self._treeArch = "i386"
42
 
@@ -925,9 +925,9 @@ class DebianDistro(Distro):
43
 
         if fetcher.hasFile("%s/MANIFEST" % self._prefix):
44
 
             # For regular trees
45
 
             pass
46
 
-        elif fetcher.hasFile("images/daily/MANIFEST"):
47
 
+        elif fetcher.hasFile("daily/MANIFEST"):
48
 
             # For daily trees
49
 
-            self._prefix = "images/daily"
50
 
+            self._prefix = "daily"
51
 
             self._set_media_paths()
52
 
         else:
53
 
             return False