~ubuntu-branches/ubuntu/raring/nova/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/fix-libvirt-tests.patch

  • Committer: Package Import Robot
  • Author(s): Chuck Short, Adam Gandelman, Chuck Short
  • Date: 2012-11-23 09:04:58 UTC
  • mfrom: (1.1.66)
  • Revision ID: package-import@ubuntu.com-20121123090458-91565o7aev1i1h71
Tags: 2013.1~g1-0ubuntu1
[ Adam Gandelman ]
* debian/control: Ensure novaclient is upgraded with nova,
  require python-keystoneclient >= 1:2.9.0. (LP: #1073289)
* debian/patches/{ubuntu/*, rbd-security.patch}: Dropped, applied
  upstream.
* debian/control: Add python-testtools to Build-Depends.

[ Chuck Short ]
* New upstream version.
* Refreshed debian/patches/avoid_setuptools_git_dependency.patch.
* debian/rules: FTBFS if missing binaries.
* debian/nova-scheudler.install: Add missing rabbit-queues and
  nova-rpc-zmq-receiver.
* Remove nova-volume since it doesnt exist anymore, transition to cinder-*.
* debian/rules: install apport hook in the right place.
* debian/patches/ubuntu-show-tests.patch: Display test failures.
* debian/control: Add depends on genisoimage
* debian/control: Suggest guestmount.
* debian/control: Suggest websockify. (LP: #1076442)
* debian/nova.conf: Disable nova-volume service.
* debian/control: Depend on xen-system-* rather than the hypervisor.
* debian/control, debian/mans/nova-conductor.8, debian/nova-conductor.init,
  debian/nova-conductor.install, debian/nova-conductor.logrotate
  debian/nova-conductor.manpages, debian/nova-conductor.postrm
  debian/nova-conductor.upstart.in: Add nova-conductor service.
* debian/control: Add python-fixtures as a build deps.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 4b3fff879118fc72d0cb5840705adc5731c283ed Mon Sep 17 00:00:00 2001
 
2
From: Chuck Short <chuck.short@canonical.com>
 
3
Date: Wed, 21 Nov 2012 13:22:10 -0600
 
4
Subject: [PATCH] Pin lxml to 3.0.1
 
5
 
 
6
Bump lxml to 3.0.1. This is the most recent version available
 
7
and what it is installed by default on Ubuntu 13.04. Most modern
 
8
distributions will be updating to this version sooner or later.
 
9
 
 
10
Change-Id: I5afdd12b79776a78b714eb605886c17a4becd295
 
11
Signed-off-by: Chuck Short <chuck.short@canonical.com>
 
12
---
 
13
 nova/tests/test_libvirt_config.py | 6 +++---
 
14
 tools/pip-requires                | 2 +-
 
15
 2 files changed, 4 insertions(+), 4 deletions(-)
 
16
 
 
17
diff --git a/nova/tests/test_libvirt_config.py b/nova/tests/test_libvirt_config.py
 
18
index c285d46..dd44725 100644
 
19
--- a/nova/tests/test_libvirt_config.py
 
20
+++ b/nova/tests/test_libvirt_config.py
 
21
@@ -366,7 +366,7 @@ class LibvirtConfigGuestDiskTest(LibvirtConfigBaseTest):
 
22
         self.assertXmlEqual(xml, """
 
23
             <disk type="network" device="disk">
 
24
               <driver name="qemu" type="qcow2"/>
 
25
-              <source protocol="iscsi" name="foo.bar.com"/>
 
26
+              <source name="foo.bar.com" protocol="iscsi"/>
 
27
               <target bus="ide" dev="/dev/hda"/>
 
28
             </disk>""")
 
29
 
 
30
@@ -387,7 +387,7 @@ class LibvirtConfigGuestDiskTest(LibvirtConfigBaseTest):
 
31
         self.assertXmlEqual(xml, """
 
32
             <disk type="network" device="disk">
 
33
               <driver name="qemu" type="raw"/>
 
34
-              <source protocol="rbd" name="pool/image"/>
 
35
+              <source name="pool/image" protocol="rbd"/>
 
36
               <auth username="foo">
 
37
                 <secret type="ceph"
 
38
                 uuid="b38a3f43-4be2-4046-897f-b67c2f5e0147"/>
 
39
@@ -535,7 +535,7 @@ class LibvirtConfigGuestInterfaceTest(LibvirtConfigBaseTest):
 
40
             <interface type="direct">
 
41
               <mac address="DE:AD:BE:EF:CA:FE"/>
 
42
               <model type="virtio"/>
 
43
-              <source mode="private" dev="eth0"/>
 
44
+              <source dev="eth0" mode="private"/>
 
45
               <target dev="tap12345678"/>
 
46
               <virtualport type="802.1Qbh"/>
 
47
             </interface>""")
 
48