~ubuntu-branches/ubuntu/raring/obconf/raring

« back to all changes in this revision

Viewing changes to debian/patches/revert_new_button_layout.patch

  • Committer: Package Import Robot
  • Author(s): Luca Falavigna
  • Date: 2011-12-15 23:15:55 UTC
  • mfrom: (4.1.5 precise)
  • Revision ID: package-import@ubuntu.com-20111215231555-xj4oomytat7bjabc
* QA upload.
* New upstream snapshot is built with openbox 3.5 (Closes: #652199).
* Switch to format 3.0 (quilt).
* debian/patches/pt_BR.patch:
  - Brazilian Portuguese translation (Closes: #607492).
* debian/compat:
  - Bump compatibility level to 8.
* debian/control:
  - Set Maintainer to Debian QA Group.
  - Build-depend on dh-autoreconf, drop autotools-dev and automake.
  - Build-depend on libimlib2-dev.
  - Bump Standards-Version to 3.9.2.
  - Remove Vcs-* fields.
  - Add ${misc:Depends} to Depends field.
* debian/copyright:
  - Use versioned link to common-licenses.
* debian/obconf.pod:
  - Fix syntax error appearing with pod2man.
* debian/rules:
  - Switch to dh.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Revert new button layout
 
2
Authors: Julien Lavergne <gilir@ubuntu.com>
 
3
 
 
4
Index: obconf-2.0.3+git20110808/src/preview.c
 
5
===================================================================
 
6
--- obconf-2.0.3+git20110808.orig/src/preview.c 2011-08-05 18:05:10.000000000 +0200
 
7
+++ obconf-2.0.3+git20110808/src/preview.c      2011-12-15 22:39:01.551540140 +0100
 
8
@@ -327,28 +327,28 @@
 
9
             switch (*layout) {
 
10
             case 'D':
 
11
                 a = focus ?
 
12
-                    theme->btn_desk->a_focused_unpressed :
 
13
-                    theme->btn_desk->a_unfocused_unpressed;
 
14
+                    theme->a_focused_unpressed_desk :
 
15
+                    theme->a_unfocused_unpressed_desk;
 
16
                 break;
 
17
             case 'S':
 
18
                 a = focus ?
 
19
-                    theme->btn_shade->a_focused_unpressed :
 
20
-                    theme->btn_shade->a_unfocused_unpressed;
 
21
+                    theme->a_focused_unpressed_shade :
 
22
+                    theme->a_unfocused_unpressed_shade;
 
23
                 break;
 
24
             case 'I':
 
25
                 a = focus ?
 
26
-                    theme->btn_iconify->a_focused_unpressed :
 
27
-                    theme->btn_iconify->a_unfocused_unpressed;
 
28
+                    theme->a_focused_unpressed_iconify :
 
29
+                    theme->a_unfocused_unpressed_iconify;
 
30
                 break;
 
31
             case 'M':
 
32
                 a = focus ?
 
33
-                    theme->btn_max->a_focused_unpressed :
 
34
-                    theme->btn_max->a_unfocused_unpressed;
 
35
+                    theme->a_focused_unpressed_max :
 
36
+                    theme->a_unfocused_unpressed_max;
 
37
                 break;
 
38
             case 'C':
 
39
                 a = focus ?
 
40
-                    theme->btn_close->a_focused_unpressed :
 
41
-                    theme->btn_close->a_unfocused_unpressed;
 
42
+                    theme->a_focused_unpressed_close :
 
43
+                    theme->a_unfocused_unpressed_close;
 
44
                 break;
 
45
             default:
 
46
                 continue;