~ubuntu-branches/ubuntu/raring/python2.7/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/db5.1.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-03-08 14:30:55 UTC
  • Revision ID: package-import@ubuntu.com-20130308143055-gyzjn6vv7szlqsiw
Tags: 2.7.3-16ubuntu1
* Merge with Debian; remaining changes:
  - Build-depend on python:any instead of python.
* Update symbols files.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: b/setup.py
2
 
===================================================================
3
1
--- a/setup.py
4
2
+++ b/setup.py
5
 
@@ -799,7 +799,7 @@
 
3
@@ -877,7 +877,7 @@
6
4
         # a release.  Most open source OSes come with one or more
7
5
         # versions of BerkeleyDB already installed.
8
6
 
11
9
         min_db_ver = (4, 1)
12
10
         db_setup_debug = False   # verbose debug prints from this script?
13
11
 
14
 
@@ -821,7 +821,11 @@
 
12
@@ -899,7 +899,11 @@
15
13
             return True
16
14
 
17
15
         def gen_db_minor_ver_nums(major):
24
22
                 for x in range(max_db_ver[1]+1):
25
23
                     if allow_db_ver((4, x)):
26
24
                         yield x
27
 
Index: b/Lib/bsddb/__init__.py
28
 
===================================================================
29
25
--- a/Lib/bsddb/__init__.py
30
26
+++ b/Lib/bsddb/__init__.py
31
27
@@ -33,7 +33,7 @@
37
33
 
38
34
 For the full featured object oriented interface use the bsddb.db module
39
35
 instead.  It mirrors the Oracle Berkeley DB C API.
40
 
Index: b/Lib/bsddb/test/test_all.py
41
 
===================================================================
42
36
--- a/Lib/bsddb/test/test_all.py
43
37
+++ b/Lib/bsddb/test/test_all.py
44
38
@@ -484,6 +484,8 @@
60
54
 get_new_path.num=0
61
55
 
62
56
 def get_test_path_prefix() :
63
 
Index: b/Lib/bsddb/test/test_associate.py
64
 
===================================================================
65
57
--- a/Lib/bsddb/test/test_associate.py
66
58
+++ b/Lib/bsddb/test/test_associate.py
67
59
@@ -76,6 +76,11 @@
88
80
     keytype = ''
89
81
     envFlags = 0
90
82
     dbFlags = 0
91
 
Index: b/Lib/bsddb/test/test_basics.py
92
 
===================================================================
93
83
--- a/Lib/bsddb/test/test_basics.py
94
84
+++ b/Lib/bsddb/test/test_basics.py
95
85
@@ -74,7 +74,6 @@
116
106
         def test_get_tx_max(self) :
117
107
             self.assertEqual(self.env.get_tx_max(), 30)
118
108
 
119
 
Index: b/Lib/bsddb/test/test_compat.py
120
 
===================================================================
121
109
--- a/Lib/bsddb/test/test_compat.py
122
110
+++ b/Lib/bsddb/test/test_compat.py
123
111
@@ -11,6 +11,11 @@
132
120
     def setUp(self):
133
121
         self.filename = get_new_database_path()
134
122
 
135
 
Index: b/Lib/bsddb/test/test_db.py
136
 
===================================================================
137
123
--- a/Lib/bsddb/test/test_db.py
138
124
+++ b/Lib/bsddb/test/test_db.py
139
125
@@ -11,6 +11,8 @@
224
210
         def test_re_len(self) :
225
211
             for i in [33, 65, 300, 2000] :
226
212
                 self.db.set_re_len(i)
227
 
Index: b/Lib/bsddb/test/test_dbenv.py
228
 
===================================================================
229
213
--- a/Lib/bsddb/test/test_dbenv.py
230
214
+++ b/Lib/bsddb/test/test_dbenv.py
231
215
@@ -25,12 +25,31 @@
292
276
 
293
277
         def test_set_cachesize_dbenv_db(self) :
294
278
             # You can not configure the cachesize using
295
 
Index: b/Lib/bsddb/test/test_dbtables.py
296
 
===================================================================
297
279
--- a/Lib/bsddb/test/test_dbtables.py
298
280
+++ b/Lib/bsddb/test/test_dbtables.py
299
281
@@ -38,6 +38,11 @@
308
290
     db_name = 'test-table.db'
309
291
 
310
292
     def setUp(self):
311
 
Index: b/Lib/bsddb/test/test_distributed_transactions.py
312
 
===================================================================
313
293
--- a/Lib/bsddb/test/test_distributed_transactions.py
314
294
+++ b/Lib/bsddb/test/test_distributed_transactions.py
315
295
@@ -19,6 +19,11 @@
340
320
 
341
321
     def setUp(self) :
342
322
         self.homeDir = get_new_environment_path()
343
 
Index: b/Lib/bsddb/test/test_get_none.py
344
 
===================================================================
345
323
--- a/Lib/bsddb/test/test_get_none.py
346
324
+++ b/Lib/bsddb/test/test_get_none.py
347
325
@@ -11,6 +11,11 @@
356
334
     def setUp(self):
357
335
         self.filename = get_new_database_path()
358
336
 
359
 
Index: b/Lib/bsddb/test/test_join.py
360
 
===================================================================
361
337
--- a/Lib/bsddb/test/test_join.py
362
338
+++ b/Lib/bsddb/test/test_join.py
363
339
@@ -30,6 +30,11 @@
372
348
     keytype = ''
373
349
 
374
350
     def setUp(self):
375
 
Index: b/Lib/bsddb/test/test_lock.py
376
 
===================================================================
377
351
--- a/Lib/bsddb/test/test_lock.py
378
352
+++ b/Lib/bsddb/test/test_lock.py
379
353
@@ -89,7 +89,6 @@
384
358
         def test03_lock_timeout(self):
385
359
             self.env.set_timeout(0, db.DB_SET_LOCK_TIMEOUT)
386
360
             self.assertEqual(self.env.get_timeout(db.DB_SET_LOCK_TIMEOUT), 0)
387
 
Index: b/Lib/bsddb/test/test_misc.py
388
 
===================================================================
389
361
--- a/Lib/bsddb/test/test_misc.py
390
362
+++ b/Lib/bsddb/test/test_misc.py
391
363
@@ -97,10 +97,6 @@
399
371
         try:
400
372
             db1 = db.DB()
401
373
             db1.set_flags(db.DB_DUPSORT)
402
 
Index: b/Lib/bsddb/test/test_queue.py
403
 
===================================================================
404
374
--- a/Lib/bsddb/test/test_queue.py
405
375
+++ b/Lib/bsddb/test/test_queue.py
406
376
@@ -99,11 +99,6 @@
415
385
         d = db.DB()
416
386
         d.set_re_len(40)  # Queues must be fixed length
417
387
         d.open(self.filename, db.DB_QUEUE, db.DB_CREATE)
418
 
Index: b/Lib/bsddb/test/test_recno.py
419
 
===================================================================
420
388
--- a/Lib/bsddb/test/test_recno.py
421
389
+++ b/Lib/bsddb/test/test_recno.py
422
390
@@ -236,7 +236,9 @@
460
428
 
461
429
 #----------------------------------------------------------------------
462
430
 
463
 
Index: b/Modules/_bsddb.c
464
 
===================================================================
465
431
--- a/Modules/_bsddb.c
466
432
+++ b/Modules/_bsddb.c
467
433
@@ -202,9 +202,7 @@
1696
1662
 
1697
1663
         strcpy(py_api_name, _bsddbModuleName);
1698
1664
         strcat(py_api_name, ".api");
1699
 
Index: b/Modules/bsddb.h
1700
 
===================================================================
1701
1665
--- a/Modules/bsddb.h
1702
1666
+++ b/Modules/bsddb.h
1703
1667
@@ -109,7 +109,7 @@