~ubuntu-branches/ubuntu/raring/python2.7/raring-proposed

« back to all changes in this revision

Viewing changes to debian/patches/sysconfigdata.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2013-03-08 14:30:55 UTC
  • Revision ID: package-import@ubuntu.com-20130308143055-gyzjn6vv7szlqsiw
Tags: 2.7.3-16ubuntu1
* Merge with Debian; remaining changes:
  - Build-depend on python:any instead of python.
* Update symbols files.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: b/Lib/sysconfig.py
2
 
===================================================================
3
1
--- a/Lib/sysconfig.py
4
2
+++ b/Lib/sysconfig.py
5
 
@@ -330,9 +330,10 @@
 
3
@@ -334,9 +334,10 @@
6
4
         return os.path.join(_PROJECT_BASE, "Makefile")
7
5
     return os.path.join(get_path('platstdlib').replace("/usr/local","/usr",1), "config" + (sys.pydebug and "_d" or ""), "Makefile")
8
6
 
16
14
     # load the installed Makefile:
17
15
     makefile = _get_makefile_filename()
18
16
     try:
19
 
@@ -360,6 +361,19 @@
 
17
@@ -364,6 +365,19 @@
20
18
     if _PYTHON_BUILD:
21
19
         vars['LDSHARED'] = vars['BLDSHARED']
22
20
 
36
34
 def _init_non_posix(vars):
37
35
     """Initialize the module as appropriate for NT"""
38
36
     # set basic install directories
39
 
Index: b/Makefile.pre.in
40
 
===================================================================
41
37
--- a/Makefile.pre.in
42
38
+++ b/Makefile.pre.in
43
 
@@ -378,7 +378,7 @@
 
39
@@ -409,7 +409,7 @@
44
40
 
45
41
 # Default target
46
42
 all:           build_all
49
45
 
50
46
 # Compile a binary with gcc profile guided optimization.
51
47
 profile-opt:
52
 
@@ -406,6 +406,7 @@
 
48
@@ -438,6 +438,7 @@
53
49
        $(MAKE) clean
54
50
        $(MAKE) all PY_CFLAGS="$(PY_CFLAGS) -O0 -pg -fprofile-arcs -ftest-coverage" LIBS="$(LIBS) -lgcov"
55
51
 
57
53
 
58
54
 # Build the interpreter
59
55
 $(BUILDPYTHON):        Modules/python.o $(LIBRARY) $(LDLIBRARY)
60
 
@@ -413,15 +414,21 @@
 
56
@@ -445,15 +446,21 @@
61
57
                        Modules/python.o \
62
58
                        -Wl,--whole-archive $(BLDLIBRARY) -Wl,--no-whole-archive $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
63
59
 
64
60
-platform: $(BUILDPYTHON)
65
61
+platform: $(BUILDPYTHON) $(SYSCONFIGDATA)
66
 
        $(RUNSHARED) ./$(BUILDPYTHON) -E -c 'import sys ; from sysconfig import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
 
62
        $(RUNSHARED) $(PYTHON_FOR_BUILD) -c 'import sys ; from sysconfig import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
67
63
 
68
64
+# Generate the sysconfig build-time data
69
65
+$(SYSCONFIGDATA): $(BUILDPYTHON)
81
77
        @case "$$MAKEFLAGS" in \
82
78
            *\ -s*|s*) quiet="-q";; \
83
79
            *) quiet="";; \
84
 
@@ -917,7 +924,7 @@
 
80
@@ -963,7 +970,7 @@
85
81
                else    true; \
86
82
                fi; \
87
83
        done
90
86
        do \
91
87
                if test -x $$i; then \
92
88
                        $(INSTALL_SCRIPT) $$i $(DESTDIR)$(LIBDEST); \
93
 
Index: b/Lib/distutils/sysconfig.py
94
 
===================================================================
95
89
--- a/Lib/distutils/sysconfig.py
96
90
+++ b/Lib/distutils/sysconfig.py
97
 
@@ -434,66 +434,11 @@
 
91
@@ -425,66 +425,11 @@
98
92
 
99
93
 def _init_posix():
100
94
     """Initialize the module as appropriate for POSIX systems."""