~ubuntu-branches/ubuntu/saucy/bochs/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_libtool.patch

  • Committer: Bazaar Package Importer
  • Author(s): David Futcher
  • Date: 2009-04-30 07:46:11 UTC
  • mfrom: (1.1.11 upstream) (4.1.7 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090430074611-6dih80a5mk2uvxhk
Tags: 2.3.7+20090416-1ubuntu1
* Merge from debian unstable (LP: #370427), remaining changes:
  - debian/patches/12_no-ssp.patch: Build bios with -fno-stack-protector
  - Add Replaces/Conflicts for bochsbios-qemu (<< 2.3.6-2)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: b/gui/Makefile.in
2
 
===================================================================
 
1
---
 
2
 configure.in      |    4 ++--
 
3
 gui/Makefile.in   |   28 ++++++++++++++--------------
 
4
 iodev/Makefile.in |   26 +++++++++++++-------------
 
5
 3 files changed, 29 insertions(+), 29 deletions(-)
 
6
 
3
7
--- a/gui/Makefile.in
4
8
+++ b/gui/Makefile.in
5
9
@@ -113,47 +113,47 @@ libgui.a: $(NONPLUGIN_OBJS)
64
68
 
65
69
 #### building DLLs for win32  (tested on cygwin only)
66
70
 bx_%.dll: %.o
67
 
Index: b/iodev/Makefile.in
68
 
===================================================================
69
71
--- a/iodev/Makefile.in
70
72
+++ b/iodev/Makefile.in
71
 
@@ -130,41 +130,41 @@ pcidev.o : pcidev.@CPP_SUFFIX@
 
73
@@ -132,44 +132,44 @@ pcidev.o : pcidev.@CPP_SUFFIX@
72
74
 
73
75
 ##### building plugins with libtool
74
76
 %.lo: %.@CPP_SUFFIX@
92
94
-       $(LIBTOOL) --mode=link $(CXX) -module keyboard.lo scancodes.lo -o libbx_keyboard.la -rpath $(PLUGIN_PATH)
93
95
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module keyboard.lo scancodes.lo -o libbx_keyboard.la -rpath $(PLUGIN_PATH)
94
96
 
95
 
 libbx_pit.la: pit82c54.lo pit_wrap.lo
 
97
 libbx_pit_wrap.la: pit82c54.lo pit_wrap.lo
96
98
-       $(LIBTOOL) --mode=link $(CXX) -module pit82c54.lo pit_wrap.lo -o libbx_pit.la -rpath $(PLUGIN_PATH)
97
99
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module pit82c54.lo pit_wrap.lo -o libbx_pit.la -rpath $(PLUGIN_PATH)
98
100
 
99
101
 libbx_sb16.la: sb16.lo $(SOUNDLOW_OBJS:.o=.lo)
100
 
-       $(LIBTOOL) --mode=link $(CXX) -module sb16.lo $(SOUNDLOW_OBJS:.o=.lo) -o libbx_sb16.la -rpath $(PLUGIN_PATH)
101
 
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module sb16.lo $(SOUNDLOW_OBJS:.o=.lo) -o libbx_sb16.la -rpath $(PLUGIN_PATH)
 
102
-       $(LIBTOOL) --mode=link $(CXX) -module sb16.lo $(SOUNDLOW_OBJS:.o=.lo) -o libbx_sb16.la -rpath $(PLUGIN_PATH) $(SOUND_LINK_OPTS)
 
103
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module sb16.lo $(SOUNDLOW_OBJS:.o=.lo) -o libbx_sb16.la -rpath $(PLUGIN_PATH) $(SOUND_LINK_OPTS)
102
104
 
103
105
 libbx_ne2k.la: ne2k.lo $(NETLOW_OBJS:.o=.lo)
104
106
-       $(LIBTOOL) --mode=link $(CXX) -module ne2k.lo $(NETLOW_OBJS:.o=.lo) -o libbx_ne2k.la -rpath $(PLUGIN_PATH)
116
118
-       $(LIBTOOL) --mode=link $(CXX) -module vga.lo svga_cirrus.lo -o libbx_vga.la -rpath $(PLUGIN_PATH)
117
119
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module vga.lo svga_cirrus.lo -o libbx_vga.la -rpath $(PLUGIN_PATH)
118
120
 
119
 
 libbx_pciusb.la: pciusb.lo usb_hid.lo usb_msd.lo scsi_device.lo hdimage.lo cdrom.lo
120
 
-       $(LIBTOOL) --mode=link $(CXX) -module pciusb.lo usb_hid.lo usb_msd.lo scsi_device.lo hdimage.lo cdrom.lo -o libbx_pciusb.la -rpath $(PLUGIN_PATH)
121
 
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module pciusb.lo usb_hid.lo usb_msd.lo scsi_device.lo hdimage.lo cdrom.lo -o libbx_pciusb.la -rpath $(PLUGIN_PATH)
 
121
 libbx_usb_uhci.la: usb_uhci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo
 
122
-       $(LIBTOOL) --mode=link $(CXX) -module usb_uhci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo -o libbx_usb_uhci.la -rpath $(PLUGIN_PATH)
 
123
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module usb_uhci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo -o libbx_usb_uhci.la -rpath $(PLUGIN_PATH)
 
124
 
 
125
 libbx_usb_ohci.la: usb_ohci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo
 
126
-       $(LIBTOOL) --mode=link $(CXX) -module usb_ohci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo -o libbx_usb_ohci.la -rpath $(PLUGIN_PATH)
 
127
+       $(LIBTOOL) --mode=link --tag CXX $(CXX) -module usb_ohci.lo $(USBDEV_OBJS:.o=.lo) scsi_device.lo hdimage.lo cdrom.lo -o libbx_usb_ohci.la -rpath $(PLUGIN_PATH)
122
128
 
123
129
 #### building DLLs for win32  (tested on cygwin only)
124
130
 bx_%.dll: %.o
125
 
Index: b/configure.in
126
 
===================================================================
127
131
--- a/configure.in
128
132
+++ b/configure.in
129
 
@@ -2171,8 +2171,8 @@ OFP="-o "
 
133
@@ -2301,8 +2301,8 @@ OFP="-o "
130
134
 MAKELIB="ar rv \$@"
131
135
 RMCOMMAND="rm -f "
132
136
 # first define link variables without libtool