~ubuntu-branches/ubuntu/saucy/darktable/saucy

« back to all changes in this revision

Viewing changes to debian/patches/0001-Add-Wno-error-unused-but-set-variable.patch

  • Committer: Bazaar Package Importer
  • Author(s): David Bremner
  • Date: 2011-07-12 09:36:46 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20110712093646-yp9dbxan44dmw15h
Tags: 0.9-1
* New upstream release.
* Remove all patches now upstream; only patch for
  -Wno-error=unused-but-set-variable remains.
* Bump Standards-Version to 3.9.2 (no changes)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From faa5749d65fbaf75a28516c2eafa335719d2c600 Mon Sep 17 00:00:00 2001
 
2
From: David Bremner <bremner@debian.org>
 
3
Date: Tue, 3 May 2011 22:18:13 -0300
 
4
Subject: [PATCH] Add -Wno-error=unused-but-set-variable
 
5
 
 
6
This prevents the build failing when GCC 4.6.1 stops passing this flag
 
7
by default.
 
8
---
 
9
 src/CMakeLists.txt |    2 ++
 
10
 1 files changed, 2 insertions(+), 0 deletions(-)
 
11
 
 
12
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
 
13
index eca98aa..55ba1c4 100644
 
14
--- a/src/CMakeLists.txt
 
15
+++ b/src/CMakeLists.txt
 
16
@@ -220,6 +220,8 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fno-strict-aliasing")
 
17
 if(NOT APPLE)
 
18
   # apple build fails on deprecated warnings..
 
19
   set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
 
20
+  # New warning in GCC 4.6.1, not yet fixed everywhere.
 
21
+  set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-error=unused-but-set-variable")
 
22
 endif(NOT APPLE)
 
23
 
 
24
 if(NOT WIN32)
 
25
-- 
 
26
1.7.5.4
 
27