~ubuntu-branches/ubuntu/saucy/dsniff/saucy

« back to all changes in this revision

Viewing changes to debian/patches/09_sshcrypto.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): William Vera
  • Date: 2011-06-15 00:43:02 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20110615004302-k4ppsvvodyw2yurx
Tags: 2.4b1+debian-21
* Changed patch system to quilt from dpatch. 
* Updated debian/README.source for quilt. 
* Removed lintian override. 
* Cleanup the debian/rules. 
* Build-Depend changed to libdb-dev (>= 4.7) (Closes: #548478). 
* Added urlsnarf patch (Closes: #573365).
   + Thanks Hilko Bengen. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 09_sshcrypto.dpatch by Steve Kemp <skx@debian.org>
3
 
##
4
 
## DP: Missing openssl  includes in sshcrypto.c. 
5
 
## DP: This patch was through diff.gz and now is implemented as a dpatch.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad dsniff-2.4b1~/sshcrypto.c dsniff-2.4b1/sshcrypto.c
9
 
--- dsniff-2.4b1~/sshcrypto.c   2006-11-02 23:41:11.000000000 -0300
10
 
+++ dsniff-2.4b1/sshcrypto.c    2006-11-02 23:41:55.000000000 -0300
11
 
@@ -14,6 +14,8 @@
12
 
 
13
 
 #include <sys/types.h>
14
 
 #include <openssl/ssl.h>
15
 
+#include <openssl/blowfish.h>
16
 
+#include <openssl/des.h>
17
 
 
18
 
 #include <err.h>
19
 
 #include <stdio.h>