~ubuntu-branches/ubuntu/saucy/dsniff/saucy

« back to all changes in this revision

Viewing changes to debian/patches/09_sshcrypto.patch

  • Committer: Bazaar Package Importer
  • Author(s): William Vera
  • Date: 2011-06-15 00:43:02 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: james.westby@ubuntu.com-20110615004302-k4ppsvvodyw2yurx
Tags: 2.4b1+debian-21
* Changed patch system to quilt from dpatch. 
* Updated debian/README.source for quilt. 
* Removed lintian override. 
* Cleanup the debian/rules. 
* Build-Depend changed to libdb-dev (>= 4.7) (Closes: #548478). 
* Added urlsnarf patch (Closes: #573365).
   + Thanks Hilko Bengen. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Steve Kemp <skx@debian.org>
 
2
Description: Missing openssl  includes in sshcrypto.c. 
 
3
This patch was through diff.gz and now is implemented as a dpatch.
 
4
--- a/sshcrypto.c       2011-06-19 17:13:57.971999389 -0500
 
5
+++ b/sshcrypto.c       2011-06-19 17:15:19.847999373 -0500
 
6
@@ -14,6 +14,8 @@
 
7
 
 
8
 #include <sys/types.h>
 
9
 #include <openssl/ssl.h>
 
10
+#include <openssl/blowfish.h>
 
11
+#include <openssl/des.h>
 
12
 
 
13
 #include <err.h>
 
14
 #include <stdio.h>