~ubuntu-branches/ubuntu/saucy/f-spot/saucy

« back to all changes in this revision

Viewing changes to debian/patches/debian_link-system-flickrnet.patch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane
  • Date: 2010-05-24 10:35:57 UTC
  • mfrom: (2.4.7 experimental)
  • Revision ID: james.westby@ubuntu.com-20100524103557-1j0i8f66caybci2n
Tags: 0.7.0-1
* New upstream release 0.7.0
 + First release of the unstable 0.7 development series. Massive changes.
 + Reparenting and detaching support (Anton Keks) (Closes: #559745)
 + A new Mallard-based documentation (Harold Schreckengost)
 + No longer embeds flickrnet, uses distribution copy (Iain Lane)
 + Adoption of a large amount of Hyena functionality (Paul Lange, Peter
   Goetz)
 + No longer embeds gnome-keyring-sharp
 + Completely rewritten import, much faster and less memory hungry (Ruben
   Vermeersch) (Closes: #559080, #492658, #341790, #357811, #426017) (LP:
   #412091)
 + No longer use gphoto2-sharp, now uses gvfs which is less crash-pron
   (Ruben Vermeersch)
 + Fix Facebook support (Ruben Vermeersch)
 + Modernized unit tests
 + Revamped build (Mike Gemünde)
 + Much improved duplicate detection (much faster too) (Ruben Vermeersch)
 + Mouse selection in Iconview (Vincent Pomey)
 + Image panning support using middle mouse button (Wojciech Dzierżanowski)
 + Timeline slider now restricted to the size of the window (Iain Churcher)
 + Over 100 bugs closed (http://bit.ly/cyVjnD)
   - No more warnings about schema defaults (Closes: #584215) (LP: #586132)
* debian/control: Clean up build deps to match configure checks
* debian/rules: Don't run dh_makeshilbs as we don't ship any shared
  libraries. There are some private ones though, which get picked up and
  result in a useless postinst/postrm call to ldconfig. Thanks, lintian.
* debian/patches/debian_fix-distclean.patch,
  debian/patches/debian_fix_f-spot.exe.config.patch,
  debian/patches/debian_link-system-flickrnet.patch,
  debian/patches/debian_link-system-gnome-keyring.patch,
  debian/patches/debian_disable-unit-tests,
  debian/patches/git_transition_duration.patch,
  debian/patches/ubuntu_fix_folder_export_hang.patch:
  Clean up obsolete patches which are no longer necessary 
* debian/patches/*: Temporarily disable patches which originated from Ubuntu
  and no longer apply cleanly. We will get these back in a future upstream
  development release.
* debian/patches/*: Refresh to apply cleanly 
* debian/rules: Add new include dir to autoreconf call to pick up f-spot
  macros 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## link_system_flickrnet.dpatch by Tim Retout <tim@retout.co.uk>
3
 
## ported to new upstream by Chris Coulson <chrisccoulson@googlemail.com>
4
 
##
5
 
## All lines beginning with `## DP:' are a description of the patch.
6
 
## DP: Link against system flickrnet-2.1.5 rather than bundled f-spot version.
7
 
 
8
 
@DPATCH@
9
 
Index: f-spot.git/configure.ac
10
 
===================================================================
11
 
--- f-spot.git.orig/configure.ac        2010-05-17 11:59:36.000000000 +0100
12
 
+++ f-spot.git/configure.ac     2010-05-17 16:37:43.976710072 +0100
13
 
@@ -376,7 +376,6 @@
14
 
 extensions/Exporters/Makefile
15
 
 extensions/Exporters/CDExport/Makefile
16
 
 extensions/Exporters/FlickrExport/Makefile
17
 
-extensions/Exporters/FlickrExport/FlickrNet/Makefile
18
 
 extensions/Exporters/GalleryExport/Makefile
19
 
 extensions/Exporters/FacebookExport/Makefile
20
 
 extensions/Exporters/FolderExport/Makefile
21
 
Index: f-spot.git/extensions/Exporters/FlickrExport/Makefile.am
22
 
===================================================================
23
 
--- f-spot.git.orig/extensions/Exporters/FlickrExport/Makefile.am       2010-05-17 11:59:36.000000000 +0100
24
 
+++ f-spot.git/extensions/Exporters/FlickrExport/Makefile.am    2010-05-17 16:43:30.046709088 +0100
25
 
@@ -19,16 +19,13 @@
26
 
        $(LINK_GIOSHARP)                        \
27
 
        $(LINK_GTKSHARPBEANS)                   \
28
 
        $(LINK_UNIQUESHARP)                     \
29
 
-       -r:FlickrNet/FlickrNet.dll      \
30
 
        -r:Mono.Posix
31
 
 
32
 
 PKGS =                                 \
33
 
+    -pkg:flickrnet \
34
 
        -pkg:gtk-sharp-2.0              \
35
 
        -pkg:glade-sharp-2.0
36
 
 
37
 
-SUBDIRS =                      \
38
 
-       FlickrNet
39
 
-
40
 
 RESOURCES =                            \
41
 
        -resource:$(srcdir)/$(PLUGIN_MANIFEST)  \
42
 
        -resource:$(srcdir)/$(PLUGIN_NAME).glade