~ubuntu-branches/ubuntu/saucy/gfan/saucy-proposed

« back to all changes in this revision

Viewing changes to debian/patches/dont_forget_flags_debian.patch

  • Committer: Package Import Robot
  • Author(s): Cédric Boutillier
  • Date: 2013-07-09 10:44:01 UTC
  • mfrom: (2.1.2 experimental)
  • Revision ID: package-import@ubuntu.com-20130709104401-5q66ozz5j5af0dak
Tags: 0.5+dfsg-3
* Upload to unstable.
* modify remove_failing_tests_on_32bits.patch to replace command of
  0009RenderStairCase test with an empty one instead of deleting it.
* remove lintian override about spelling error

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Use CXXFLAGS/LDFLAGS exported by dpkg-dev
 
2
Author: Cédric Boutillier <boutil@debian.org>
 
3
Last-Update: 2013-01-16
 
4
 
 
5
--- a/Makefile
 
6
+++ b/Makefile
 
7
@@ -82,10 +82,10 @@
 
8
 CXX         = g++
 
9
 CCLINKER    = $(CXX)
 
10
 #OPTFLAGS    = -O2 -DGMPRATIONAL -DNDEBUG
 
11
-OPTFLAGS    = -O2 -DGMPRATIONAL -Wuninitialized
 
12
+OPTFLAGS    = -DGMPRATIONAL -Wuninitialized
 
13
 
 
14
-CFLAGS   = $(OPTFLAGS) $(GPROFFLAG) $(ADDITIONALINCLUDEOPTIONS) #-pedantic
 
15
-CCFLAGS          = $(CFLAGS)
 
16
+CFLAGS   += $(OPTFLAGS) $(ADDITIONALINCLUDEOPTIONS) #-pedantic
 
17
+CXXFLAGS  += $(OPTFLAGS) $(ADDITIONALINCLUDEOPTIONS)
 
18
 FFLAGS   = $(OPTFLAGS)
 
19
 
 
20
 CATSOBJECTS =  $(GCATSPATH)lp_cdd.o \
 
21
@@ -317,7 +317,7 @@
 
22
 default: $(OBJECTS) $(ADDITIONALOBJECTS) $(EXECS)
 
23
 
 
24
 $(MAIN): $(OBJECTS)
 
25
-       $(CCLINKER) $(OBJECTS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
 
26
+       $(CCLINKER) $(OBJECTS) $(LDFLAGS) $(ADDITIONALLINKOPTIONS) $(GPROFFLAG) -o $(MAIN)
 
27
 
 
28
 release:
 
29
        rm -f -r $(RELEASEDIR)/*
 
30
@@ -431,11 +431,11 @@
 
31
        cp gfanlib_* gfanlib/
 
32
        tar zcf -  gfanlib > gfanlib.tar.gz
 
33
 .c.o:
 
34
-       $(CC) $(CFLAGS) -c $<
 
35
+       $(CC) $(CPPFLAGS) $(CFLAGS) -c $<
 
36
 .cc.o:
 
37
        $(CXX) -c $<
 
38
 .cpp.o:
 
39
-       $(CXX) $(CFLAGS) -c $<
 
40
+       $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $<
 
41
 .C.o:
 
42
        $(CXX) -c $<
 
43
 # wget http://ftp.sunet.se/pub/gnu/gmp/gmp-4.2.2.tar.gz