~ubuntu-branches/ubuntu/saucy/libunique/saucy

« back to all changes in this revision

Viewing changes to debian/patches/01_format-security.patch

  • Committer: Package Import Robot
  • Author(s): Michael Biebl
  • Date: 2011-10-27 20:39:50 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: package-import@ubuntu.com-20111027203950-s790rgfbhfxqx3b3
Tags: 1.1.6-3
* Switch to dpkg source format 3.0 (quilt).
* Bump debhelper compatibility level to 8.
  - Update Build-Depends on debhelper.
  - Strip debian/tmp/ from .install files.
* debian/control.in:
  - Bump Standards-Version to 3.9.2. No further changes.
  - Add Vcs-* fields.
* debian/rules:
  - Disable -Werror. Closes: #625376
* debian/patches/01_format-security.patch:
  - Fix build failures with -Werror=format-security.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: libunique-1.1.6/tests/test-unique.c
 
2
===================================================================
 
3
--- libunique-1.1.6.orig/tests/test-unique.c    2009-09-21 14:31:14.000000000 +0200
 
4
+++ libunique-1.1.6/tests/test-unique.c 2011-10-27 20:31:38.869186701 +0200
 
5
@@ -82,9 +82,11 @@
 
6
                                    GTK_DIALOG_DESTROY_WITH_PARENT,
 
7
                                    GTK_MESSAGE_INFO,
 
8
                                    GTK_BUTTONS_CLOSE,
 
9
+                                   "%s",
 
10
                                    title);
 
11
   if (message)
 
12
     gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG (dialog),
 
13
+                                              "%s",
 
14
                                               message);
 
15
 
 
16
   gtk_window_set_urgency_hint (GTK_WINDOW (dialog), TRUE);