~ubuntu-branches/ubuntu/saucy/libunique/saucy

« back to all changes in this revision

Viewing changes to debian/patches/git_warning_fix.patch

  • Committer: Package Import Robot
  • Author(s): Michael Biebl
  • Date: 2011-10-27 20:39:50 UTC
  • mfrom: (2.1.7 sid)
  • Revision ID: package-import@ubuntu.com-20111027203950-s790rgfbhfxqx3b3
Tags: 1.1.6-3
* Switch to dpkg source format 3.0 (quilt).
* Bump debhelper compatibility level to 8.
  - Update Build-Depends on debhelper.
  - Strip debian/tmp/ from .install files.
* debian/control.in:
  - Bump Standards-Version to 3.9.2. No further changes.
  - Add Vcs-* fields.
* debian/rules:
  - Disable -Werror. Closes: #625376
* debian/patches/01_format-security.patch:
  - Fix build failures with -Werror=format-security.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/unique/dbus/uniquebackend-dbus.c b/unique/dbus/uniquebackend-dbus.c
2
 
index 3ae1bed..69faa00 100644
3
 
--- a/unique/dbus/uniquebackend-dbus.c
4
 
+++ b/unique/dbus/uniquebackend-dbus.c
5
 
@@ -84,7 +84,6 @@ unique_backend_dbus_register_proxy (UniqueBackendDBus *backend_dbus)
6
 
 static gboolean
7
 
 unique_backend_dbus_request_name (UniqueBackend *backend)
8
 
 {
9
 
-  UniqueBackendDBus *backend_dbus;
10
 
   const gchar *name;
11
 
   DBusGConnection *connection;
12
 
   DBusGProxy *proxy;
13
 
@@ -97,8 +96,6 @@ unique_backend_dbus_request_name (UniqueBackend *backend)
14
 
   if (!connection)
15
 
     return FALSE;
16
 
 
17
 
-  backend_dbus = UNIQUE_BACKEND_DBUS (backend);
18
 
-
19
 
   retval = TRUE;
20
 
   name = unique_backend_get_name (backend);
21
 
   g_assert (name != NULL);
22
 
@@ -207,10 +204,14 @@ unique_backend_dbus_send_message (UniqueBackend     *backend,
23
 
                                         cmd, data, time_,
24
 
                                         &resp,
25
 
                                         &error);
26
 
-  if (error)
27
 
+  if (!res)
28
 
     {
29
 
-      g_warning ("Error while sending message: %s", error->message);
30
 
-      g_error_free (error);
31
 
+      if (error)
32
 
+        {
33
 
+          g_warning ("Error while sending message: %s", error->message);
34
 
+          g_error_free (error);
35
 
+        }
36
 
+
37
 
       g_free (cmd);
38
 
       
39
 
       return UNIQUE_RESPONSE_INVALID;
40
 
diff --git a/unique/uniqueapp.c b/unique/uniqueapp.c
41
 
index 873321d..82bd48f 100644
42
 
--- a/unique/uniqueapp.c
43
 
+++ b/unique/uniqueapp.c
44
 
@@ -782,7 +782,7 @@ unique_app_watch_window (UniqueApp *app,
45
 
 }
46
 
 
47
 
 
48
 
-G_CONST_RETURN gchar *
49
 
+const gchar *
50
 
 unique_command_to_string (UniqueApp *app,
51
 
                           gint       command)
52
 
 {
53
 
@@ -864,7 +864,7 @@ unique_command_from_string (UniqueApp   *app,
54
 
   return retval;
55
 
 }
56
 
 
57
 
-G_CONST_RETURN gchar *
58
 
+const gchar *
59
 
 unique_response_to_string (UniqueResponse response)
60
 
 {
61
 
   GEnumClass *enum_class;
62
 
diff --git a/unique/uniquebackend.c b/unique/uniquebackend.c
63
 
index a407f72..cfc8a21 100644
64
 
--- a/unique/uniquebackend.c
65
 
+++ b/unique/uniquebackend.c
66
 
@@ -109,7 +109,7 @@ unique_backend_set_name (UniqueBackend *backend,
67
 
  *
68
 
  * Return value: FIXME
69
 
  */
70
 
-G_CONST_RETURN gchar *
71
 
+const gchar *
72
 
 unique_backend_get_name (UniqueBackend *backend)
73
 
 {
74
 
   g_return_val_if_fail (UNIQUE_IS_BACKEND (backend), NULL);
75
 
@@ -152,7 +152,7 @@ unique_backend_set_startup_id (UniqueBackend *backend,
76
 
  *
77
 
  * Return value: FIXME
78
 
  */
79
 
-G_CONST_RETURN gchar *
80
 
+const gchar *
81
 
 unique_backend_get_startup_id (UniqueBackend *backend)
82
 
 {
83
 
   g_return_val_if_fail (UNIQUE_IS_BACKEND (backend), NULL);
84
 
diff --git a/unique/uniquebackend.h b/unique/uniquebackend.h
85
 
index a50ce4e..b19ad3e 100644
86
 
--- a/unique/uniquebackend.h
87
 
+++ b/unique/uniquebackend.h
88
 
@@ -94,10 +94,10 @@ GType                 unique_backend_get_type       (void) G_GNUC_CONST;
89
 
 
90
 
 UniqueBackend *       unique_backend_create         (void);
91
 
 
92
 
-G_CONST_RETURN gchar *unique_backend_get_name       (UniqueBackend     *backend);
93
 
+const gchar *         unique_backend_get_name       (UniqueBackend     *backend);
94
 
 void                  unique_backend_set_name       (UniqueBackend     *backend,
95
 
                                                      const gchar       *name);
96
 
-G_CONST_RETURN gchar *unique_backend_get_startup_id (UniqueBackend     *backend);
97
 
+const gchar *         unique_backend_get_startup_id (UniqueBackend     *backend);
98
 
 void                  unique_backend_set_startup_id (UniqueBackend     *backend,
99
 
                                                      const gchar       *startup_id);
100
 
 GdkScreen *           unique_backend_get_screen     (UniqueBackend     *backend);
101
 
diff --git a/unique/uniqueinternals.h b/unique/uniqueinternals.h
102
 
index 3cec152..ccae0cd 100644
103
 
--- a/unique/uniqueinternals.h
104
 
+++ b/unique/uniqueinternals.h
105
 
@@ -44,11 +44,11 @@ UniqueResponse unique_app_emit_message_received (UniqueApp         *app,
106
 
  * and then back into an id
107
 
  */
108
 
 UniqueResponse        unique_response_from_string  (const gchar    *response);
109
 
-G_CONST_RETURN gchar *unique_response_to_string    (UniqueResponse  response);
110
 
+const gchar *         unique_response_to_string    (UniqueResponse  response);
111
 
 
112
 
 gint                  unique_command_from_string   (UniqueApp      *app,
113
 
                                                     const gchar    *command);
114
 
-G_CONST_RETURN gchar *unique_command_to_string     (UniqueApp      *app,
115
 
+const gchar *         unique_command_to_string     (UniqueApp      *app,
116
 
                                                     gint            command);
117
 
 
118
 
 G_END_DECLS
119
 
diff --git a/unique/uniquemessage.c b/unique/uniquemessage.c
120
 
index e39b531..415c951 100644
121
 
--- a/unique/uniquemessage.c
122
 
+++ b/unique/uniquemessage.c
123
 
@@ -184,7 +184,7 @@ unique_message_data_set (UniqueMessageData *message_data,
124
 
  *
125
 
  * Since: 1.0.2
126
 
  */
127
 
-G_CONST_RETURN guchar *
128
 
+const guchar *
129
 
 unique_message_data_get (UniqueMessageData *message_data,
130
 
                          gsize             *length)
131
 
 {
132
 
@@ -529,7 +529,7 @@ unique_message_data_get_screen (UniqueMessageData *message_data)
133
 
  *   owned by the #UniqueMessageData structure and should not be
134
 
  *   modified or freed
135
 
  */
136
 
-G_CONST_RETURN gchar *
137
 
+const gchar *
138
 
 unique_message_data_get_startup_id (UniqueMessageData *message_data)
139
 
 {
140
 
   g_return_val_if_fail (message_data != NULL, NULL);
141
 
diff --git a/unique/uniquemessage.h b/unique/uniquemessage.h
142
 
index b862d43..b06b048 100644
143
 
--- a/unique/uniquemessage.h
144
 
+++ b/unique/uniquemessage.h
145
 
@@ -48,7 +48,7 @@ void                   unique_message_data_free           (UniqueMessageData *me
146
 
 void                   unique_message_data_set            (UniqueMessageData *message_data,
147
 
                                                            const guchar      *data,
148
 
                                                            gsize              length);
149
 
-G_CONST_RETURN guchar *unique_message_data_get            (UniqueMessageData *message_data,
150
 
+const guchar *         unique_message_data_get            (UniqueMessageData *message_data,
151
 
                                                            gsize             *length);
152
 
 
153
 
 gboolean               unique_message_data_set_text       (UniqueMessageData *message_data,
154
 
@@ -63,7 +63,7 @@ void                   unique_message_data_set_filename   (UniqueMessageData *me
155
 
 gchar *                unique_message_data_get_filename   (UniqueMessageData *message_data);
156
 
 
157
 
 GdkScreen *            unique_message_data_get_screen     (UniqueMessageData *message_data);
158
 
-G_CONST_RETURN gchar * unique_message_data_get_startup_id (UniqueMessageData *message_data);
159
 
+const gchar *          unique_message_data_get_startup_id (UniqueMessageData *message_data);
160
 
 guint                  unique_message_data_get_workspace  (UniqueMessageData *message_data);
161
 
 
162
 
 G_END_DECLS